summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD27
-rw-r--r--atlassian-bitbucket.install6
-rw-r--r--bitbucket.service14
5 files changed, 38 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 762d9a1e367f..89d1c2eea887 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,28 @@
-# Generated by mksrcinfo v8
-# Wed Sep 7 18:58:56 UTC 2016
pkgbase = atlassian-bitbucket
pkgdesc = Bitbucket Server
- pkgver = 4.9.1
+ pkgver = 6.8.0
pkgrel = 1
url = https://www.atlassian.com/software/bitbucket/server
install = atlassian-bitbucket.install
arch = i686
arch = x86_64
license = custom
- depends = java-runtime=8
+ depends = java-runtime
depends = git>=1.8.0
depends = perl>=5.8.8
optdepends = haveged: Entropy for the ssh plugin
+ backup = var/lib/bitbucket/shared/bitbucket.properties
backup = etc/systemd/system/bitbucket.service.d/local.conf
+ backup = var/lib/bitbucket/server.xml
backup = etc/bitbucket/server.xml
- source = https://atlassian.com/software/stash/downloads/binary/atlassian-bitbucket-4.9.1.tar.gz
+ source = https://atlassian.com/software/stash/downloads/binary/atlassian-bitbucket-6.8.0.tar.gz
source = bitbucket.service
source = bitbucket.tmpfiles
source = bitbucket.sysusers
- source = local.conf
- sha256sums = cc8833c9f69f9f33f89ca0a7ebd7efe2e604b5e37e1e77f3500c26217dfa6855
- sha256sums = cdba0049a5ed6757aa469baa194383d51664f04f6a17e23e7f7e4935201ce629
- sha256sums = d7c7735e2b092b58c89c272ae1afe8122a51d2b8edc5c46ccdd470c29ef1cfc1
- sha256sums = 4fd916cab8d0004678fca749d45858e265d0ab698b7d3a6de038a62b72a7c17f
- sha256sums = 487d9067e07aa741b2ef2ce52e81d506c962ab59d3c31fd4876d7a4ee53573e2
+ md5sums = 8b032214e26daae913be089c996436fe
+ md5sums = 5ec83b341eb186731b0fce80b1ed3aa3
+ md5sums = ba53070cb05fe18c5c04a0860b139938
+ md5sums = ed617ba7cf3f829ef3bcbe9cc558c4d7
pkgname = atlassian-bitbucket
diff --git a/.gitignore b/.gitignore
index 4ad4e9154c29..72e8ffc0db8a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,9 +1 @@
-*.pkg.tar
-*.src.tar.gz
-pkg/
-src/
-*.sw[op]
-*.pkg.tar.xz
-atlassian-bitbucket*.tar.gz
-atlassian-bitbucket-*/
-*.part
+*
diff --git a/PKGBUILD b/PKGBUILD
index de18c7083aec..f77becf1af1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
_pkgname=bitbucket
pkgname=atlassian-${_pkgname}
-pkgver=4.9.1
+pkgver=6.8.0
pkgrel=1
pkgdesc="Bitbucket Server"
url="https://www.atlassian.com/software/${_pkgname}/server"
license=("custom")
arch=("i686" "x86_64")
-depends=("java-runtime=8"
+depends=("java-runtime"
"git>=1.8.0"
"perl>=5.8.8")
optdepends=("haveged: Entropy for the ssh plugin" )
-backup=("etc/systemd/system/${_pkgname}.service.d/local.conf"
+backup=("var/lib/${_pkgname}/shared/${_pkgname}.properties"
+ "etc/systemd/system/${_pkgname}.service.d/local.conf"
+ "var/lib/bitbucket/server.xml"
"etc/${_pkgname}/server.xml")
install="$pkgname.install"
source=("https://atlassian.com/software/stash/downloads/binary/${pkgname}-${pkgver}.tar.gz"
"${_pkgname}.service"
"${_pkgname}.tmpfiles"
- "${_pkgname}.sysusers"
- "local.conf")
+ "${_pkgname}.sysusers")
package() {
install -dm750 "$pkgdir/var/lib/${_pkgname}"
@@ -25,23 +26,21 @@ package() {
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
cp -r "$srcdir/atlassian-${_pkgname}-$pkgver/licenses/"* "$pkgdir/usr/share/licenses/$pkgname"
cp -r "$srcdir/atlassian-${_pkgname}-$pkgver/"* "$pkgdir/opt/$pkgname"
- install -Dm755 "$pkgdir/opt/$pkgname/conf/server.xml" "$pkgdir/etc/${_pkgname}/server.xml"
- rm "$pkgdir/opt/$pkgname/conf/server.xml"
+ install -dm750 "$pkgdir/etc/${_pkgname}"
+ #install -Dm755 "$pkgdir/opt/$pkgname/conf/server.xml" "$pkgdir/etc/${_pkgname}/server.xml"
+ #rm "$pkgdir/opt/$pkgname/conf/server.xml"
ln -s "/etc/${_pkgname}/server.xml" "$pkgdir/var/lib/${_pkgname}/server.xml"
# remove unneeded Windows files
find "$pkgdir/opt/$pkgname/bin" -name "*.bat" -type f -exec rm "{}" \;
find "$pkgdir/opt/$pkgname/bin" -name "*.exe" -type f -exec rm "{}" \;
-
# setup systemd service
install -Dm644 "$srcdir/${_pkgname}.service" "$pkgdir/usr/lib/systemd/system/${_pkgname}.service"
- install -Dm644 "$srcdir/local.conf" "$pkgdir/etc/systemd/system/${_pkgname}.service.d/local.conf"
install -Dm644 "$srcdir/${_pkgname}.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/${_pkgname}.conf"
install -Dm644 "$srcdir/${_pkgname}.sysusers" "$pkgdir/usr/lib/sysusers.d/${_pkgname}.conf"
}
-sha256sums=('cc8833c9f69f9f33f89ca0a7ebd7efe2e604b5e37e1e77f3500c26217dfa6855'
- 'cdba0049a5ed6757aa469baa194383d51664f04f6a17e23e7f7e4935201ce629'
- 'd7c7735e2b092b58c89c272ae1afe8122a51d2b8edc5c46ccdd470c29ef1cfc1'
- '4fd916cab8d0004678fca749d45858e265d0ab698b7d3a6de038a62b72a7c17f'
- '487d9067e07aa741b2ef2ce52e81d506c962ab59d3c31fd4876d7a4ee53573e2')
+md5sums=('8b032214e26daae913be089c996436fe'
+ '5ec83b341eb186731b0fce80b1ed3aa3'
+ 'ba53070cb05fe18c5c04a0860b139938'
+ 'ed617ba7cf3f829ef3bcbe9cc558c4d7')
diff --git a/atlassian-bitbucket.install b/atlassian-bitbucket.install
index c81f351ca180..9aea054b0338 100644
--- a/atlassian-bitbucket.install
+++ b/atlassian-bitbucket.install
@@ -1,7 +1,7 @@
post_install() {
- systemd-sysusers bitbucket.conf
- systemd-tmpfiles --create bitbucket.conf
- chown -R bitbucket:bitbucket /opt/atlassian-bitbucket /etc/bitbucket
+ #systemd-sysusers bitbucket.conf
+ #systemd-tmpfiles --create bitbucket.conf
+ chown -R bitbucket:bitbucket /opt/atlassian-bitbucket /etc/bitbucket /var/lib/bitbucket
chmod -R 750 /etc/bitbucket
echo "If you are running bitbucket in a VM and/or are experiencing trouble with the ssh-plugin, it might be necessary to enable haveged."
}
diff --git a/bitbucket.service b/bitbucket.service
index cc91bd5fbab6..21e489e11c5c 100644
--- a/bitbucket.service
+++ b/bitbucket.service
@@ -3,12 +3,22 @@ Description=Bitbucket Server by Atlassian
After=network.target
[Service]
-Type=forking
+User=bitbucket
+SyslogIdentifier=bitbucket
+Environment="BITBUCKET_HOME=/var/lib/bitbucket"
+Environment="CATALINA_HOME=/opt/atlassian-bitbucket"
+Environment="CATALINA_BASE=/opt/atlassian-bitbucket"
+Environment="CATALINA_TMPDIR=/opt/atlassian-bitbucket/temp"
+Environment="JAVA_HOME=/usr/lib/jvm/default"
+Environment="CLASSPATH=/opt/atlassian-bitbucket/app"
+EnvironmentFile=-/etc/conf.d/bitbucket
ExecStart=/opt/atlassian-bitbucket/bin/start-bitbucket.sh
ExecStop=/opt/atlassian-bitbucket/bin/stop-bitbucket.sh
-PIDFile=/opt/atlassian-bitbucket/work/catalina.pid
+Type=forking
+PIDFile=/var/lib/bitbucket/log/bitbucket.pid
KillSignal=SIGINT
LimitNOFILE=8196
+SuccessExitStatus=143
[Install]
WantedBy=multi-user.target