summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD28
-rw-r--r--atom-editor-bin.install21
-rw-r--r--atom-python.patch37
5 files changed, 127 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e93442e103e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = atom-editor-bin
+ pkgdesc = Chrome-based text editor from Github - Precompiled binary from official repository
+ pkgver = 0.207.0
+ pkgrel = 1
+ url = https://github.com/atom/atom
+ install = atom-editor-bin.install
+ arch = x86_64
+ license = MIT
+ depends = git
+ depends = gconf
+ depends = gtk2
+ depends = libnotify
+ depends = libxtst
+ depends = nss
+ depends = python2
+ depends = gvfs
+ depends = xdg-utils
+ depends = desktop-file-utils
+ conflicts = atom-editor
+ conflicts = atom-editor-git
+ conflicts = atom-editor-git-tagged
+ options = !strip
+ source = https://github.com/atom/atom/releases/download/v0.207.0/atom-amd64.deb
+ source = atom-python.patch
+ md5sums = e27d0f38169cde45bb0d5257d5f75c90
+ md5sums = dbb685607dea46517de0a27e24085bf4
+
+pkgname = atom-editor-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fd287aeafcde
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,12 @@
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+pkg/
+src/
+
+# atom deb package
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09560526e0ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer Danny Arnold <despair.blue at gmail dot com>
+# Contributor: Andre Miranda <andreldm1989 AT gmail DOT com>
+# Contributor: Tom Bu <tom.bu AT members.fsf.org>
+# Contributor: John Reese <john@noswap.com>
+# Upstream URL: https://github.com/atom/atom
+
+pkgname=atom-editor-bin
+pkgver=0.207.0
+pkgrel=1
+pkgdesc="Chrome-based text editor from Github - Precompiled binary from official repository"
+arch=('x86_64')
+url="https://github.com/atom/atom"
+license=('MIT')
+options=(!strip)
+depends=('git' 'gconf' 'gtk2' 'libnotify' 'libxtst' 'nss' 'python2' 'gvfs' 'xdg-utils' 'desktop-file-utils')
+conflicts=('atom-editor' 'atom-editor-git' 'atom-editor-git-tagged')
+install=$pkgname.install
+
+md5sums=('e27d0f38169cde45bb0d5257d5f75c90'
+ 'dbb685607dea46517de0a27e24085bf4')
+source=("https://github.com/atom/atom/releases/download/v${pkgver}/atom-amd64.deb"
+ atom-python.patch)
+package() {
+ bsdtar xf data.tar.gz
+ patch -p1 < "${srcdir}"/atom-python.patch
+ chmod -R g-w usr
+ mv usr "${pkgdir}"
+}
diff --git a/atom-editor-bin.install b/atom-editor-bin.install
new file mode 100644
index 000000000000..959a05111b50
--- /dev/null
+++ b/atom-editor-bin.install
@@ -0,0 +1,21 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+_update() {
+ msg_blue "Updating desktop MIME database..."
+ update-desktop-database -q
+}
+
+post_install() {
+ _update
+}
+
+post_upgrade() {
+ _update
+}
+
+post_remove() {
+ _update
+}
diff --git a/atom-python.patch b/atom-python.patch
new file mode 100644
index 000000000000..af5e42399a7c
--- /dev/null
+++ b/atom-python.patch
@@ -0,0 +1,37 @@
+--- a/usr/bin/atom
++++ b/usr/bin/atom
+@@ -1,5 +1,8 @@
+ #!/bin/bash
+
++export PYTHON=python2
++unset GTK_IM_MODULE QT_IM_MODULE XMODIFIERS
++
+ if [ "$(uname)" == 'Darwin' ]; then
+ OS='Mac'
+ elif [ "$(expr substr $(uname -s) 1 5)" == 'Linux' ]; then
+
+
+--- a/usr/share/applications/atom.desktop
++++ b/usr/share/applications/atom.desktop
+@@ -2,7 +2,7 @@
+ Name=Atom
+ Comment=A hackable text editor for the 21st Century.
+ GenericName=Text Editor
+-Exec=/usr/share/atom/atom %U
++Exec=env PYTHON=python2 GTK_IM_MODULE= QT_IM_MODULE= XMODIFIERS= /usr/share/atom/atom %U
+ Icon=atom
+ Type=Application
+ StartupNotify=true
+
+
+--- a/usr/share/atom/resources/app/apm/bin/apm
++++ b/usr/share/atom/resources/app/apm/bin/apm
+@@ -2,6 +2,8 @@
+
+ set -e
+
++export PYTHON=python2
++
+ initialCwd=`pwd -P`
+
+ apmPath=$0