summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore2
-rw-r--r--Makefile8
-rw-r--r--PKGBUILD17
4 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee0536b8780f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = atomicwallet
+ pkgdesc = Atomic Wallet is a decentralized Cryptocurrency wallet that supports more than 500 coins and tokens, providing simplicity, safety, and convenience for its users.
+ pkgver = 2.26.5
+ pkgrel = 1
+ url = https://atomicwallet.io
+ arch = x86_64
+ license = unknown
+ source = https://get.atomicwallet.io/download/atomicwallet-2.26.5-116.AppImage
+ sha256sums = ff649f16dcf9fffd5da8832b564bdc219f7959277f3673c443e6d5c3331b643f
+
+pkgname = atomicwallet
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9f438acc0584
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.AppImage
+*.pkg.tar.xz
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..4f09e42a93f2
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,8 @@
+.PHONY: post clean
+
+post:
+ makepkg --verifysource -f
+ makepkg --printsrcinfo > .SRCINFO
+
+clean:
+ git clean -fX
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a84f0665e1e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: David Barri <japgolly@gmail.com>
+pkgname=atomicwallet
+pkgver=2.26.5
+pkgrel=1
+pkgdesc="Atomic Wallet is a decentralized Cryptocurrency wallet that supports more than 500 coins and tokens, providing simplicity, safety, and convenience for its users."
+arch=('x86_64')
+url="https://atomicwallet.io"
+license=('unknown')
+source=("https://get.atomicwallet.io/download/atomicwallet-$pkgver-116.AppImage")
+sha256sums=('ff649f16dcf9fffd5da8832b564bdc219f7959277f3673c443e6d5c3331b643f')
+options=('!strip')
+
+package() {
+ set -eu
+
+ install -Dm755 atomicwallet-$pkgver-*.AppImage "$pkgdir/usr/bin/atomicwallet"
+}