summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD43
2 files changed, 26 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f81faa43690d..d7d197f0c179 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,24 @@
+# Generated by mksrcinfo v8
+# Sat Dec 3 17:20:06 UTC 2016
pkgbase = atomzombiesmasher-hib
pkgdesc = A 2D tactics/strategy game where you evacuate civilians from zombie-infested cities. (Humble Bundle/Store version)
- pkgver = 1.953+h20130409
- pkgrel = 2
+ pkgver = 2+h20161017
+ pkgrel = 1
url = http://blendogames.com/atomzombiesmasher/
arch = any
license = custom:commercial
depends = mono
- depends = libgdiplus
- depends = csfml-bin
depends = openal
depends = flac
- depends = libpng12
- depends = libjpeg6
- depends = libtiff3
depends = xdg-utils
conflicts = atomzombiesmasherdemo
conflicts = atomzombiesmasher
conflicts = atomzombiesmasher-demo
replaces = atomzombiesmasher
- source = atomzombiesmasher_v1_953-er.tar.gz::hib://atomzombiesmasher_v1_953-er.tar.gz
+ source = atomzombiesmasher-10172016-bin::hib://atomzombiesmasher-10172016-bin
source = atomzombiesmasher.desktop
source = https://apps.ubuntu.com/site_media/icons/2013/12/atom-zombie-smashertCCn9V.png
- md5sums = 6902c845a21e92c62f5b33b38715c797
+ md5sums = af521890276792589bdfd5f1882a8c2b
md5sums = b1f2e18834d1bec5785a889f642e2191
md5sums = 341ce551a8525be96d6c59c1bf9efd2a
diff --git a/PKGBUILD b/PKGBUILD
index 7daebb144aff..9dd40ed8b8f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,25 @@
# Based on work by Malte Wessel <muunleit AT lavabit DOT com>
pkgname=atomzombiesmasher-hib
-pkgver=1.953+h20130409
-_hibver=v1_953-er
-pkgrel=2
+pkgver=2+h20161017
+_hibver=10172016
+pkgrel=1
pkgdesc="A 2D tactics/strategy game where you evacuate civilians from zombie-infested cities. (Humble Bundle/Store version)"
arch=('any')
url="http://blendogames.com/atomzombiesmasher/"
license=("custom:commercial")
-depends=('mono' 'libgdiplus' 'csfml-bin' 'openal' 'flac' 'libpng12' 'libjpeg6' 'libtiff3' 'xdg-utils')
+depends=('mono' 'openal' 'flac' 'xdg-utils')
conflicts=("atomzombiesmasherdemo" "atomzombiesmasher" "atomzombiesmasher-demo")
replaces=("atomzombiesmasher")
PKGEXT='.pkg.tar'
-_gamepkg="atomzombiesmasher_$_hibver.tar.gz"
+_gamepkg="atomzombiesmasher-$_hibver-bin"
source=("$_gamepkg::hib://$_gamepkg"
"atomzombiesmasher.desktop"
"https://apps.ubuntu.com/site_media/icons/2013/12/atom-zombie-smashertCCn9V.png")
-md5sums=("6902c845a21e92c62f5b33b38715c797"
- "b1f2e18834d1bec5785a889f642e2191"
- "341ce551a8525be96d6c59c1bf9efd2a")
+md5sums=('af521890276792589bdfd5f1882a8c2b'
+ 'b1f2e18834d1bec5785a889f642e2191'
+ '341ce551a8525be96d6c59c1bf9efd2a')
_installname=atomzombiesmasher
case $CARCH in
@@ -30,39 +30,36 @@ case $CARCH in
esac
prepare() {
- cd atomzombiesmasher
-
msg2 "Prepare launch script..."
echo -e "#!/usr/bin/sh\n" \
"export MONO_WINFORMS_XIM_STYLE=disabled\n" \
"cd /opt/$_installname\n" \
- "exec mono AtomZombieSmasher.exe" '"$@"' \
- > game/$_installname
+ "export LD_LIBRARY_PATH='./$_lib:\$LD_LIBRARY_PATH'\n" \
+ 'exec mono AtomZombieSmasher.exe "$@"' \
+ > data/$_installname
msg2 "Fix permissions..."
find -type f -exec chmod 644 {} \;
- chmod 755 game/$_installname
+ chmod 755 data/$_installname
msg2 "Remove unneeded files..."
- rm game/AtomZombieSmasher.bin.*
- rm -r game/$_libother
- rm -r game/$_lib/{libmono*,libMono*,libcsfml*,libsfml*}
- rm -r game/$_lib/{libopenal.so.1,libFLAC.so.8,libgdiplus.so}
- rm -r game/$_lib/{libjpeg.so.62,libpng12.so.0,libtiff.so.3}
- rm -r game/{mono,{Accessibility,Mono*,mscorlib,System*}.dll}
+ rm data/AtomZombieSmasher{,.bin.*}
+ rm data/$_lib/{libopenal.so.1,libSDL2-2.0.so.0}
+ rm data/{Mono*,System*,mscorlib}.dll
+ rm -r data/$_libother
# Set apart files to install separately
- mv readme.html "$srcdir"
+ mv data/Linux.README .
}
package() {
# Game data
install -g games -d "$pkgdir"/opt/$_installname
- cp -rT $_installname/game "$pkgdir"/opt/$_installname
+ cp -rT data "$pkgdir"/opt/$_installname
# Readme
- install -Dm644 readme.html \
- "$pkgdir"/usr/share/doc/$_installname/readme.html
+ install -Dm644 Linux.README \
+ "$pkgdir"/usr/share/doc/$_installname/Linux.README
# Desktop entry
install -Dm644 $_installname.desktop \