summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD26
3 files changed, 23 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04ab1a6227f3..fc6e8cc24b40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = auctex
pkgdesc = An extensible package for writing and formatting TeX files in Emacs
- pkgver = 12.3
+ pkgver = 13.3
pkgrel = 1
url = https://www.gnu.org/software/auctex/
install = auctex.install
arch = any
- license = GPL3
+ license = GPL-3.0-only
depends = emacs
depends = ghostscript
- depends = texlive-core
- source = https://ftp.gnu.org/pub/gnu/auctex/auctex-12.3.tar.gz
- source = https://ftp.gnu.org/pub/gnu/auctex/auctex-12.3.tar.gz.sig
+ depends = texlive-latexextra
+ source = https://ftp.gnu.org/pub/gnu/auctex/auctex-13.3.tar.gz
+ source = https://ftp.gnu.org/pub/gnu/auctex/auctex-13.3.tar.gz.sig
validpgpkeys = 70CDE487C45540307F86972BE2FD58BF20485F50
- sha256sums = 2fd4fe30b69457c9277fe204d3e83c8472bcf500c8fe4a810d744406174ca9dd
+ sha256sums = 4f7e57e1241a499f34861d59f3c4652fb47e3896c7a2768edbbbec1e54c91252
sha256sums = SKIP
pkgname = auctex
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..22014802e2e8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*~
+*.log
+auctex-*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 802b069ce1f1..a1d7f863dfeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,35 @@
-# Maintainer: smallst <smallst@smallst.cn>
-# Maintainer: LinRs <LinRs AT users.noreply.github.com>
+# Maintainer: Stephan Springer <buzo+arch@Lini.de>
+# Contributor: smallst <smallst@smallst.cn>
+# Contributor:: LinRs <LinRs AT users.noreply.github.com>
# Contributor: Eric Bélanger <eric@archlinux.org>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor:: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=auctex
-pkgver=12.3
+pkgver=13.3
pkgrel=1
pkgdesc="An extensible package for writing and formatting TeX files in Emacs"
arch=('any')
url="https://www.gnu.org/software/auctex/"
-license=('GPL3')
-depends=('emacs' 'ghostscript' 'texlive-core')
+license=(GPL-3.0-only)
+depends=(emacs ghostscript texlive-latexextra)
install=auctex.install
-source=("https://ftp.gnu.org/pub/gnu/auctex/${pkgname}-${pkgver}.tar.gz"{,.sig})
-sha256sums=('2fd4fe30b69457c9277fe204d3e83c8472bcf500c8fe4a810d744406174ca9dd'
+source=("https://ftp.gnu.org/pub/gnu/auctex/$pkgname-$pkgver.tar.gz"{,.sig})
+sha256sums=('4f7e57e1241a499f34861d59f3c4652fb47e3896c7a2768edbbbec1e54c91252'
'SKIP')
-validpgpkeys=('70CDE487C45540307F86972BE2FD58BF20485F50') #Mosè Giordano <mose@gnu.org>
+validpgpkeys=('70CDE487C45540307F86972BE2FD58BF20485F50') # Mosè Giordano <mose@gnu.org>
prepare() {
- cd ${pkgname}-${pkgver}
+ cd "$pkgname-$pkgver"
sed -i 's/as_fn_error $? "--with-texmf-dir=/echo as_fn_error $? "--with-texmf-dir=/' configure
}
build() {
- cd ${pkgname}-${pkgver}
+ cd "$pkgname-$pkgver"
./configure --prefix=/usr --localstatedir=/var --with-texmf-dir=/usr/share/texmf
make
}
package() {
- cd ${pkgname}-${pkgver}
+ cd "$pkgname-$pkgver"
make DESTDIR="${pkgdir}" install
}