summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
-rw-r--r--auctex.install8
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b56be97f041
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Mar 27 09:15:56 UTC 2019
+pkgbase = auctex
+ pkgdesc = An extensible package for writing and formatting TeX files in Emacs
+ pkgver = 12.1
+ pkgrel = 1
+ url = http://www.gnu.org/software/auctex/
+ install = auctex.install
+ arch = any
+ license = GPL3
+ depends = emacs
+ depends = ghostscript
+ depends = texlive-core
+ options = !makeflags
+ source = https://ftp.gnu.org/pub/gnu/auctex/auctex-12.1.tar.gz
+ source = https://ftp.gnu.org/pub/gnu/auctex/auctex-12.1.tar.gz.sig
+ sha1sums = 7744738f59fbb0862edb89eb2d47920b0f94c18b
+ sha1sums = SKIP
+
+pkgname = auctex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f103e8887a4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer:
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=auctex
+pkgver=12.1
+pkgrel=1
+pkgdesc="An extensible package for writing and formatting TeX files in Emacs"
+arch=('any')
+url="http://www.gnu.org/software/auctex/"
+license=('GPL3')
+depends=('emacs' 'ghostscript' 'texlive-core')
+options=('!makeflags')
+install=auctex.install
+source=(https://ftp.gnu.org/pub/gnu/auctex/${pkgname}-${pkgver}.tar.gz{,.sig})
+sha1sums=('7744738f59fbb0862edb89eb2d47920b0f94c18b'
+ 'SKIP')
+validpgpkeys=('70CDE487C45540307F86972BE2FD58BF20485F50')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ sed -i 's/as_fn_error $? "--with-texmf-dir=/echo as_fn_error $? "--with-texmf-dir=/' configure
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr --localstatedir=/var --with-texmf-dir=/usr/share/texmf
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/auctex.install b/auctex.install
new file mode 100644
index 000000000000..016b29cad20c
--- /dev/null
+++ b/auctex.install
@@ -0,0 +1,8 @@
+post_install() {
+cat << EOF
+==> For GNU Emacs, the recommended way to activate AUCTeX and preview-latex is to add the
+==> following lines to your ~/.emacs file:
+(load "auctex.el" nil t t)
+(load "preview-latex.el" nil t t)
+EOF
+}