summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bced83660834..8c4246a24bb3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = auditwheel
pkgdesc = Cross-distribution Linux wheels
- pkgver = 2.0.0
- pkgrel = 2
+ pkgver = 3.3.0
+ pkgrel = 1
url = https://github.com/pypa/auditwheel
arch = any
license = MIT
+ makedepends = install-wheel-scripts
depends = python-wheel
depends = python-pyelftools
- noextract = auditwheel-2.0.0-py3-none-any.whl
- source = https://files.pythonhosted.org/packages/py3/a/auditwheel/auditwheel-2.0.0-py3-none-any.whl
- sha256sums = 63fe2fdda4d6c5f7b04e3982896428e3c243fdf8b8543aaa567bf0e1ce26b44a
+ noextract = auditwheel-3.3.0-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py3/a/auditwheel/auditwheel-3.3.0-py3-none-any.whl
+ sha256sums = a462fb349b33f716c954186ea67c085a84f83dcb8421f564166224612634dbf8
pkgname = auditwheel
diff --git a/PKGBUILD b/PKGBUILD
index 9eb5e9bff515..28e98b68cf26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,23 @@
# Maintainer: Phil Schaf <flying-sheep@web.de>
pkgname=auditwheel
-pkgver=2.0.0
-pkgrel=2
+pkgver=3.3.0
+pkgrel=1
pkgdesc='Cross-distribution Linux wheels'
arch=(any)
-url="https://github.com/pypa/auditwheel"
+url="https://github.com/pypa/$pkgname"
license=(MIT)
depends=(python-wheel python-pyelftools)
+makedepends=(install-wheel-scripts)
_pyarch=py3
_wheel="$pkgname-$pkgver-$_pyarch-none-any.whl"
source=("https://files.pythonhosted.org/packages/$_pyarch/${pkgname::1}/$pkgname/$_wheel")
-sha256sums=('63fe2fdda4d6c5f7b04e3982896428e3c243fdf8b8543aaa567bf0e1ce26b44a')
+sha256sums=('a462fb349b33f716c954186ea67c085a84f83dcb8421f564166224612634dbf8')
noextract=("$_wheel")
package() {
local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
mkdir -p "$site"
unzip "$_wheel" -d "$site"
-
- cat >auditwheel.py <<-EOF
- #!/usr/bin/env python3
- from auditwheel.main import main
- main()
- EOF
- install -Dm755 auditwheel.py "$pkgdir/usr/bin/auditwheel"
+ install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel"
}