summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0163377a3a42..477bec8dc690 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = auditwheel
pkgdesc = Cross-distribution Linux wheels
- pkgver = 1.7.0
+ pkgver = 1.8.0
pkgrel = 1
url = https://github.com/pypa/auditwheel
arch = any
license = MIT
makedepends = python-pip
depends = python
- depends = python-elftools
- noextract = auditwheel-1.7.0-py3-none-any.whl
- source = https://files.pythonhosted.org/packages/14/76/290bbad9533b5749d37863008b811bb625ff3c2e76fcd8e7b9f492bf39dc/auditwheel-1.7.0-py3-none-any.whl
- sha256sums = 92b4e9bd2624c5ba06149cb186702d1dffed08bfc19d467a19291007722d0ebb
+ depends = python-pyelftools
+ noextract = auditwheel-1.8.0-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py3/a/auditwheel/auditwheel-1.8.0-py3-none-any.whl
+ sha256sums = 63468bf62d82b27b1635ffe1c3f1c4e54ef67d0a6d38bedccc38ce6965d56db7
pkgname = auditwheel
diff --git a/PKGBUILD b/PKGBUILD
index be3ea5af60db..a0b4133d4f50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,19 @@
# Maintainer: Phil Schaf <flying-sheep@web.de>
pkgname=auditwheel
-pkgver=1.7.0
+pkgver=1.8.0
pkgrel=1
pkgdesc='Cross-distribution Linux wheels'
arch=(any)
url="https://github.com/pypa/auditwheel"
license=(MIT)
-depends=(python python-elftools)
+depends=(python python-pyelftools)
makedepends=('python-pip')
_wheel="$pkgname-$pkgver-py3-none-any.whl"
-#source=("https://files.pythonhosted.org/packages/py3/${pkgname::1}/$pkgname/$_wheel")
-source=("https://files.pythonhosted.org/packages/14/76/290bbad9533b5749d37863008b811bb625ff3c2e76fcd8e7b9f492bf39dc/$_wheel")
+source=("https://files.pythonhosted.org/packages/py3/${pkgname::1}/$pkgname/$_wheel")
noextract=("$_wheel")
-sha256sums=('92b4e9bd2624c5ba06149cb186702d1dffed08bfc19d467a19291007722d0ebb')
+sha256sums=('63468bf62d82b27b1635ffe1c3f1c4e54ef67d0a6d38bedccc38ce6965d56db7')
package() {
- pip install --compile --no-deps --root="$pkgdir" "$_wheel"
+ pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
}