summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--aurto.install7
3 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 359d80b7d1fc..2a2c19773be0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = aurto
pkgdesc = An AUR tool for managing an auto-updating local 'aurto' package repository using aurutils.
- pkgver = 0.10.0
+ pkgver = 0.10.1
pkgrel = 1
url = https://github.com/alexheretic/aurto
install = aurto.install
@@ -19,8 +19,8 @@ pkgbase = aurto
backup = usr/lib/systemd/system/update-aurto.timer
backup = usr/lib/systemd/system/update-aurto-startup.timer
backup = etc/aurto/makepkg-chroot.conf
- source = https://github.com/alexheretic/aurto/archive/v0.10.0.tar.gz
- sha256sums = 136955537ff2847e18c49bfece5dfe0041f85e87134470c49a98aaabbb405d7d
+ source = https://github.com/alexheretic/aurto/archive/v0.10.1.tar.gz
+ sha256sums = 67da7661e9aaeea0f39d725be8c42b4c006541307110d1f47c376e23859fefd4
pkgname = aurto
diff --git a/PKGBUILD b/PKGBUILD
index c1a66f697347..2d0fb8cf93d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alex Butler <alexheretic@gmail.com>
pkgname=aurto
-pkgver=0.10.0
+pkgver=0.10.1
pkgrel=1
pkgdesc="An AUR tool for managing an auto-updating local 'aurto' package repository using aurutils."
arch=('any')
@@ -18,7 +18,7 @@ optdepends=()
makedepends=('cargo')
install="aurto.install"
source=("https://github.com/alexheretic/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('136955537ff2847e18c49bfece5dfe0041f85e87134470c49a98aaabbb405d7d')
+sha256sums=('67da7661e9aaeea0f39d725be8c42b4c006541307110d1f47c376e23859fefd4')
backup=('usr/lib/systemd/system/check-aurto-git-trigger.timer'
'usr/lib/systemd/system/update-aurto.timer'
'usr/lib/systemd/system/update-aurto-startup.timer'
diff --git a/aurto.install b/aurto.install
index f4a4818c4d6a..5612664c69e3 100644
--- a/aurto.install
+++ b/aurto.install
@@ -2,6 +2,9 @@
set -eu
pre_remove() {
- # aurto self cleanup
- /usr/lib/aurto/install remove
+ # If pacman.conf is still configured to use aurto warn that removing the package will break pacman
+ if grep -q '^Include = /etc/pacman.d/aurto$' /etc/pacman.conf; then
+ echo -en "\\e[33mWarning: Aurto repo is still configured. "
+ echo -e "Remove \"Include = /etc/pacman.d/aurto\" from /etc/pacman.conf\\e[39m" >&2
+ fi
}