summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2323d3ef19e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = auru-git
+ pkgdesc = AUR Utility - Check foreign packages (typically installed w/ pacman -U) for available updates in AUR and upstream websites
+ pkgver = r2.855ffb5
+ pkgrel = 1
+ url = https://github.com/semeion/auru
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python-html2text
+ depends = curl
+ depends = jq
+ depends = expac
+ optdepends = fzf
+ source = git+https://github.com/semeion/auru.git
+ sha256sums = SKIP
+
+pkgname = auru-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df47edfee707
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Alexandre Bolelli <t3k0@live.com>
+# Maintainer: Alexandre Bolelli <t3k0@live.com>
+
+pkgname=auru-git
+pkgver=r2.855ffb5
+pkgrel=1
+pkgdesc="AUR Utility - Check foreign packages (typically installed w/ pacman -U) for available updates in AUR and upstream websites"
+arch=('any')
+url='https://github.com/semeion/auru'
+license=('GPL3')
+depends=('python-html2text' 'curl' 'jq' 'expac')
+optdepends=('fzf')
+makedepends=('git')
+source=('git+https://github.com/semeion/auru.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/auru"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/auru"
+ # Install script
+ install -D -m755 auru "${pkgdir}/usr/bin/auru"
+}
+