summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD27
2 files changed, 24 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b46c57352f6a..2a07b7d3f5e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = aurutils
pkgdesc = helper tools for the arch user repository
- pkgver = 2.3.6b
+ pkgver = 2.3.7
pkgrel = 1
url = https://github.com/AladW/aurutils
- install = aurutils.install
arch = any
license = custom:ISC
+ makedepends = git
+ makedepends = signify
depends = git
depends = jq
depends = expac
@@ -15,8 +16,10 @@ pkgbase = aurutils
optdepends = bash-completion: bash completion
optdepends = devtools: aur-chroot
optdepends = vifm: build file interaction
- source = aurutils-2.3.6b.tar.gz::https://github.com/AladW/aurutils/archive/2.3.6b.tar.gz
- sha256sums = 22b12a7161635622f86cb4c4dd28c79ae9e6c23e60f3ef7985d107879c64d004
+ source = aurutils-2.3.7.tar.gz::https://github.com/AladW/aurutils/archive/2.3.7.tar.gz
+ source = aurutils-2.3.7.tar.gz.signify::https://github.com/AladW/aurutils/releases/download/2.3.7/2.3.7.tar.gz.sig
+ sha256sums = bae2f7211cb80626f260e1ebcb2c061751407a03f1ab8898bc80182888502bef
+ sha256sums = SKIP
pkgname = aurutils
diff --git a/PKGBUILD b/PKGBUILD
index 91a6f9a1edf4..9d441c687cff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,30 @@
-# Maintainer: Alad Wenter <alad@archlinux.org>
-# Co-Maintainer: Cedric Girard <cgirard.archlinux@valinor.fr>
-# Co-Maintainer: Maxim Baz <archlinux@maximbaz.com>
+# Maintainer: Alad Wenter <https://github.com/AladW>
pkgname=aurutils
-pkgver=2.3.6b
+pkgver=2.3.7
pkgrel=1
pkgdesc='helper tools for the arch user repository'
url='https://github.com/AladW/aurutils'
arch=('any')
license=('custom:ISC')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-# "$pkgname-$pkgver.tar.gz.asc::$url/releases/download/$pkgver/$pkgver.tar.gz.asc")
-install=$pkgname.install
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+ "$pkgname-$pkgver.tar.gz.signify::$url/releases/download/$pkgver/$pkgver.tar.gz.sig")
depends=('git' 'jq' 'expac' 'diffstat' 'pacutils' 'wget')
+makedepends=('git' 'signify')
optdepends=('bash-completion: bash completion'
'devtools: aur-chroot'
'vifm: build file interaction')
-sha256sums=('22b12a7161635622f86cb4c4dd28c79ae9e6c23e60f3ef7985d107879c64d004')
-# 'SKIP')
-# validpgpkeys=('DBE7D3DD8C81D58D0A13D0E76BC26A17B9B7018A') # Alad Wenter <alad@archlinux.org>
+sha256sums=('bae2f7211cb80626f260e1ebcb2c061751407a03f1ab8898bc80182888502bef'
+ 'SKIP')
+_validsignifykey='RWQawitEue1JU2SxUyRD8LXP8m36QsbaHOkKfvZBfhj00EXBYiDZilp0'
+
+prepare() {
+ cat >aurutils.pub <<EOF
+untrusted comment: signify public key
+$_validsignifykey
+EOF
+ signify -V -p aurutils.pub -m "$pkgname-$pkgver".tar.gz \
+ -x "$pkgname-$pkgver".tar.gz.signify
+}
build() {
cd "$pkgname-$pkgver"