summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--manpage.patch12
3 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03b37e465fff..556a69ba6a91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ausweisapp2
pkgdesc = A software application that you install on your computer to use your national identity card or your electronic residence permit for online identification
pkgver = 1.22.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.ausweisapp.bund.de/
arch = i686
arch = x86_64
@@ -18,9 +18,11 @@ pkgbase = ausweisapp2
optdepends = ccid
optdepends = acsccid
optdepends = pcsc-cyberjack
+ source = manpage.patch
source = https://github.com/Governikus/AusweisApp2/releases/download/1.22.0/AusweisApp2-1.22.0.tar.gz
source = https://github.com/Governikus/AusweisApp2/releases/download/1.22.0/AusweisApp2-1.22.0.tar.gz.asc
validpgpkeys = 699BF3055B0A49224EFDE7C72D7479A531451088
+ sha256sums = bd3ee7bff4ceef90fa43d14cfa9c9545e708615a0c5658bca938e347fcb1ac04
sha256sums = 6623533388516ae449741bdd53fdb5c514e84e24fa85d091e83c4c3674987561
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0e050779970f..a0ff1fa2b850 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ausweisapp2
pkgver=1.22.0
-pkgrel=1
+pkgrel=2
pkgdesc="A software application that you install on your computer to use your national identity card or your electronic residence permit for online identification"
arch=('i686' 'x86_64')
license=('custom:EUPL1.2')
@@ -10,11 +10,17 @@ url="https://www.ausweisapp.bund.de/"
depends=('qt5-declarative' 'qt5-graphicaleffects' 'qt5-quickcontrols2' 'qt5-svg' 'qt5-websockets' 'pcsclite' 'http-parser')
makedepends=('cmake' 'qt5-tools')
optdepends=('ccid' 'acsccid' 'pcsc-cyberjack')
-source=("https://github.com/Governikus/AusweisApp2/releases/download/${pkgver}/AusweisApp2-${pkgver}.tar.gz"{,.asc})
+source=("manpage.patch" "https://github.com/Governikus/AusweisApp2/releases/download/${pkgver}/AusweisApp2-${pkgver}.tar.gz"{,.asc})
validpgpkeys=('699BF3055B0A49224EFDE7C72D7479A531451088')
-sha256sums=('6623533388516ae449741bdd53fdb5c514e84e24fa85d091e83c4c3674987561'
+sha256sums=('bd3ee7bff4ceef90fa43d14cfa9c9545e708615a0c5658bca938e347fcb1ac04'
+ '6623533388516ae449741bdd53fdb5c514e84e24fa85d091e83c4c3674987561'
'SKIP')
+prepare() {
+ cd "AusweisApp2-$pkgver"
+ patch -p1 -i "${srcdir}/manpage.patch"
+}
+
build() {
cd "${srcdir}"
cmake -B build -DCMAKE_BUILD_TYPE=MinSizeRel -DCMAKE_INSTALL_PREFIX=/usr "${srcdir}/AusweisApp2-${pkgver}"
diff --git a/manpage.patch b/manpage.patch
new file mode 100644
index 000000000000..2bea34b84e01
--- /dev/null
+++ b/manpage.patch
@@ -0,0 +1,12 @@
+diff --git a/cmake/Install.cmake b/cmake/Install.cmake
+--- a/cmake/Install.cmake
++++ b/cmake/Install.cmake
+@@ -268,7 +268,7 @@ elseif(UNIX)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${BUNDLE_IDENTIFIER}.desktop DESTINATION ${CMAKE_INSTALL_DATADIR}/applications COMPONENT Application)
+ install(FILES ${RESOURCES_DIR}/images/npa.svg DESTINATION ${CMAKE_INSTALL_DATADIR}/icons/hicolor/scalable/apps COMPONENT Application RENAME AusweisApp2.svg)
+ install(FILES ${RESOURCES_DIR}/images/npa.png DESTINATION ${CMAKE_INSTALL_DATADIR}/icons/hicolor/96x96/apps COMPONENT Application RENAME AusweisApp2.png)
+- install(FILES ${DOCS_DIR}/AusweisApp2.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/ COMPONENT Application)
++ install(FILES ${DOCS_DIR}/AusweisApp2.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1 COMPONENT Application)
+ endif()
+
+