summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b01780d282e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = authbind
+ pkgdesc = Allows non-root programs to bind() to low TCP ports (0-1023)
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = http://packages.qa.debian.org/a/authbind.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ source = http://ftp.debian.org/debian/pool/main/a/authbind/authbind_2.1.1.tar.gz
+ md5sums = ef3cd5eef28519b8daf248e3761dd9bd
+
+pkgname = authbind
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..393ac80e94d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Evan Anderson <evananderson@thelinuxman.us>
+pkgname=authbind
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="Allows non-root programs to bind() to low TCP ports (0-1023)"
+arch=('i686' 'x86_64')
+url="http://packages.qa.debian.org/a/authbind.html"
+license=('GPL')
+depends=('glibc')
+source=(http://ftp.debian.org/debian/pool/main/a/${pkgname}/${pkgname}_${pkgver}.tar.gz)
+md5sums=('ef3cd5eef28519b8daf248e3761dd9bd')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make prefix=/usr
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/share/man/man1"
+ make prefix="$pkgdir/usr" etc_dir="$pkgdir/etc/authbind" install install_man
+}