summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f4915fd441e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = auto-ytdl-git
+ pkgdesc = aytdl, a youtube-dl wrapper with automatisation features for music.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/michael/auto-ytdl
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ makedepends = git
+ depends = ffmpeg
+ depends = youtube-dl
+ source = auto-ytdl::git+http://github.com/michaelb/auto-ytdl.git
+ md5sums = SKIP
+
+pkgname = auto-ytdl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b7888704760
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Michael Bleuez <michael.bleuez2 at gmail dot com>
+
+pkgname='auto-ytdl-git'
+pkgdesc='aytdl, a youtube-dl wrapper with automatisation features for music.'
+pkgver=1.0.0
+pkgrel=1
+arch=('any')
+url='https://github.com/michael/auto-ytdl'
+license=('GPL3')
+depends=('ffmpeg' 'youtube-dl')
+makedepends=('python-setuptools' 'git')
+
+md5sums=('SKIP')
+source=('auto-ytdl::git+http://github.com/michaelb/auto-ytdl.git')
+
+package() {
+ cd "${srcdir}/auto-ytdl"
+ python -m setuptools.launch setup.py install --root="$pkgdir/" --optimize=1
+}