summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d65bbdf0df2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = autocrc
+ pkgdesc = Automated CRC-checking
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/ljb/autocrc
+ arch = any
+ license = GPL3
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/a/autocrc/autocrc-1.0.tar.gz
+ sha256sums = 2c8a530cc8571aa388c677c33c3dfc73958273b4aa345c120e63f1940186006e
+
+pkgname = autocrc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37a1264ee437
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Jonas Bengtsson <jonas@bengtsson.cc>
+
+pkgname=autocrc
+pkgver=1.0
+pkgrel=1
+pkgdesc="Automated CRC-checking"
+arch=(any)
+url="https://github.com/ljb/autocrc"
+license=(GPL3)
+depends=(python)
+source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+sha256sums=('2c8a530cc8571aa388c677c33c3dfc73958273b4aa345c120e63f1940186006e')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}