summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7bd7d644e50a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = autogit
+ pkgdesc = Define commands, using plugins, to execute across all your repositories.
+ pkgver = 1.2.6
+ pkgrel = 1
+ url = https://github.com/fabiospampinato/autogit#readme
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ noextract = autogit-1.2.6.tgz
+ source = https://registry.npmjs.org/autogit/-/autogit-1.2.6.tgz
+ sha256sums = b6ac9aeab820a7d9d124762412b900fabc4d3266ebcf909fb0e2f9580d5f505a
+
+pkgname = autogit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f605a50cb5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+pkgname=autogit
+pkgver=1.2.6
+pkgrel=1
+pkgdesc="Define commands, using plugins, to execute across all your repositories."
+arch=(any)
+url="https://github.com/fabiospampinato/autogit#readme"
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm')
+optdepends=()
+source=(https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz)
+noextract=($pkgname-$pkgver.tgz)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $pkgname@$pkgver
+ find "${pkgdir}"/usr -name package.json -exec sed -i '/"_where"/d' '{}' '+'
+ find "${pkgdir}"/usr -type d -exec chmod 755 {} +
+}
+
+sha256sums=('b6ac9aeab820a7d9d124762412b900fabc4d3266ebcf909fb0e2f9580d5f505a')