summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD31
-rw-r--r--autopanovideo-beta4
-rw-r--r--autopanovideo-beta.desktop9
-rw-r--r--autopanovideo-beta.install11
6 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10eca91765d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = autopanovideo-beta
+ pkgdesc = Stitch and create 360° videos automatically with Autopano Video BETA (trial version).
+ pkgver = 3.0.0.304
+ pkgrel = 1
+ url = http://www.kolor.com/autopano-video/
+ install = autopanovideo-beta.install
+ arch = x86_64
+ license = custom: "commercial"
+ optdepends = autopanogiga: Edit control points manually
+ optdepends = gopro-vr-player: 360 video player
+ provides = autopanovideopro-beta,
+ provides = autopanovideopro,
+ provides = autopanovideo
+ source = AutopanoVideo_Linux64_3.0.0.304.tar.xz::http://download.kolor.com/avp/beta/linux64tarxz/3.0.0.304
+ source = autopanovideo-beta
+ source = autopanovideo-beta.desktop
+ sha256sums = dfa2de0dde663a42a220d87e353b1e16cf0ee7a8bf0650d8ac8d66be41110b9e
+ sha256sums = 8e9dd924c10ab925f80860c9889ab98d60c2aac35918b2331dffc2730d67383e
+ sha256sums = b141169e00ed7eb582c2c29e4555e81c03390f75a0af619b12f014f40f660b04
+
+pkgname = autopanovideo-beta
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad3bd74b0b0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Emeric <emeric.grange@gmail.com>
+# Created: 12/12/2016
+pkgname=autopanovideo-beta
+pkgver=3.0.0.304
+pkgrel=1
+pkgdesc="Stitch and create 360° videos automatically with Autopano Video BETA (trial version)."
+arch=('x86_64')
+url='http://www.kolor.com/autopano-video/'
+license=('custom: "commercial"')
+provides=('autopanovideopro-beta', 'autopanovideopro', 'autopanovideo')
+optdepends=('autopanogiga: Edit control points manually'
+ 'gopro-vr-player: 360 video player')
+install="$pkgname.install"
+_archivename=AutopanoVideo_Linux64_${pkgver}.tar.xz
+
+source=("$_archivename::http://download.kolor.com/avp/beta/linux64tarxz/${pkgver}"
+ "$pkgname"
+ "$pkgname.desktop")
+
+sha256sums=('dfa2de0dde663a42a220d87e353b1e16cf0ee7a8bf0650d8ac8d66be41110b9e'
+ '8e9dd924c10ab925f80860c9889ab98d60c2aac35918b2331dffc2730d67383e'
+ 'b141169e00ed7eb582c2c29e4555e81c03390f75a0af619b12f014f40f660b04')
+
+package() {
+ cd "$srcdir/AutopanoVideo"
+ install -dm755 $pkgdir/{opt/kolor,usr/share/licenses/$pkgname/}
+ cp -r $srcdir/AutopanoVideo $pkgdir/opt/kolor/$pkgname
+ #mv $pkgdir/opt/kolor/$pkgname/Copyright $pkgdir/usr/share/licenses/$pkgname/
+ install -Dm755 $srcdir/$pkgname $pkgdir/usr/bin/$pkgname
+ install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
diff --git a/autopanovideo-beta b/autopanovideo-beta
new file mode 100644
index 000000000000..24ed3a3b8d04
--- /dev/null
+++ b/autopanovideo-beta
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /opt/kolor/autopanovideo-beta/
+./AutopanoVideo.sh $@
diff --git a/autopanovideo-beta.desktop b/autopanovideo-beta.desktop
new file mode 100644
index 000000000000..633f8cba5b0d
--- /dev/null
+++ b/autopanovideo-beta.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Autopano Video (BETA)
+Comment=Stitch and create 360° videos automatically with Autopano Video
+Exec=autopanovideo-beta
+Icon=/opt/kolor/autopanovideo-beta/Resources/UI/AutopanoVideo.png
+Terminal=false
+Type=Application
+Categories=Application;AudioVideo;Video;
diff --git a/autopanovideo-beta.install b/autopanovideo-beta.install
new file mode 100644
index 000000000000..80312d4a6041
--- /dev/null
+++ b/autopanovideo-beta.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ update-desktop-database -q
+}
+
+post_remove() {
+ update-desktop-database -q
+}