summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--systemd-unit-dir.patch17
3 files changed, 29 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8cb4a5b7b84..c291e140740f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Tue Jan 26 05:18:24 UTC 2016
pkgbase = autorandr-git
pkgdesc = Auto-detect the connect display hardware and load the appropiate X11 setup using xrandr. Formerly autodisper. No disper support.
- pkgver = r170.ed599bc
+ pkgver = r198.ac540ff
pkgrel = 1
url = https://github.com/phillipberndt/autorandr
install = autorandr-git.install
@@ -19,8 +21,10 @@ pkgbase = autorandr-git
conflicts = autorandr-phillipberndt-git
source = autorandr::git+https://github.com/phillipberndt/autorandr.git
source = autorandr-git.install
+ source = systemd-unit-dir.patch
md5sums = SKIP
md5sums = bedb41a350cdf6983872119aef71fed6
+ md5sums = 04ccd2e108878ee07fbb3282a3f7f75f
pkgname = autorandr-git
diff --git a/PKGBUILD b/PKGBUILD
index 7750946d9cb3..9a7a8e46714d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgname=autorandr
pkgname=autorandr-git
-pkgver=r170.ed599bc
+pkgver=r198.ac540ff
pkgrel=1
pkgdesc='Auto-detect the connect display hardware and load the appropiate X11 setup using xrandr. Formerly autodisper. No disper support.'
arch=('any')
@@ -31,11 +31,11 @@ install="$pkgname.install"
source=(
"$_pkgname"::"git+https://github.com/phillipberndt/$_pkgname.git"
"$pkgname.install"
+ systemd-unit-dir.patch
)
-md5sums=(
- 'SKIP'
- 'bedb41a350cdf6983872119aef71fed6'
-)
+md5sums=('SKIP'
+ 'bedb41a350cdf6983872119aef71fed6'
+ '04ccd2e108878ee07fbb3282a3f7f75f')
pkgver() {
cd "$_pkgname"
@@ -48,13 +48,10 @@ pkgver() {
prepare() {
cd "$_pkgname"
- sed --in-place --regexp-extended 's@(#!/usr/bin/env python)@\12@' contrib/autorandr_monitor/autorandr_monitor
+ patch -p1 -i ../systemd-unit-dir.patch
}
package() {
cd "$_pkgname"
- make DESTDIR="$pkgdir" INSTALL_PATH=/usr/bin install >/dev/null
- make DESTDIR="$pkgdir" hotplug >/dev/null
-
- install -Dm755 contrib/autorandr_monitor/autorandr_monitor "$pkgdir/usr/bin/autorandr_monitor"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
}
diff --git a/systemd-unit-dir.patch b/systemd-unit-dir.patch
new file mode 100644
index 000000000000..bc5185614c2c
--- /dev/null
+++ b/systemd-unit-dir.patch
@@ -0,0 +1,17 @@
+diff --git a/Makefile b/Makefile
+index 42ee710..4803d8d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -51,10 +51,10 @@ DEFAULT_TARGETS+=systemd
+ endif
+
+ install_systemd: install_pmutils
+- install -D -m 644 contrib/systemd/autorandr-resume.service ${DESTDIR}/etc/systemd/system/autorandr-resume.service
++ install -D -m 644 contrib/systemd/autorandr-resume.service ${DESTDIR}$(shell pkg-config systemd --variable=systemdsystemunitdir)/autorandr-resume.service
+
+ uninstall_systemd: uninstall_pmutils
+- rm -f ${DESTDIR}/etc/systemd/system/autorandr-resume.service
++ rm -f ${DESTDIR}$(shell pkg-config systemd --variable=systemdsystemunitdir)/autorandr-resume.service
+
+ # Rules for udev
+ HAVE_UDEV=$(shell [ -d /etc/udev/rules.d/ ] && echo "y")