summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD85
-rw-r--r--install22
3 files changed, 148 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e698e66d1522
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = avahi-gtk2
+ pkgdesc = Multicast/unicast DNS-SD framework (with Gtk2 client apps)
+ pkgver = 0.6.31
+ pkgrel = 15
+ url = http://www.avahi.org/
+ install = install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = intltool
+ makedepends = gobject-introspection
+ makedepends = gtk2
+ makedepends = xmltoman
+ makedepends = python2
+ depends = expat
+ depends = libdaemon
+ depends = glib2
+ depends = libcap
+ depends = gdbm
+ depends = dbus
+ optdepends = gtk2: avahi-discover-standalone, bshell, bssh, bvnc, gtk2 bindings
+ optdepends = nss-mdns: NSS support for mDNS
+ provides = avahi=0.6.31
+ provides = howl
+ provides = mdnsresponder
+ conflicts = avahi
+ conflicts = howl
+ conflicts = mdnsresponder
+ replaces = avahi
+ options = !emptydirs
+ backup = etc/avahi/hosts
+ backup = etc/avahi/avahi-daemon.conf
+ backup = etc/avahi/services/ssh.service
+ backup = etc/avahi/services/sftp-ssh.service
+ backup = usr/lib/avahi/service-types.db
+ backup = usr/share/avahi/service-types
+ source = http://www.avahi.org/download/avahi-0.6.31.tar.gz
+ sha1sums = 7e05bd78572c9088b03b1207a0ad5aba38490684
+
+pkgname = avahi-gtk2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ba68d05542f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,85 @@
+# $Id: PKGBUILD 212820 2014-05-15 14:29:12Z eric $
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+
+_pkgname=avahi
+pkgname=avahi-gtk2
+pkgver=0.6.31
+pkgrel=15
+pkgdesc='Multicast/unicast DNS-SD framework (with Gtk2 client apps)'
+url='http://www.avahi.org/'
+license=('LGPL')
+arch=('i686' 'x86_64')
+options=('!emptydirs')
+depends=('expat' 'libdaemon' 'glib2' 'libcap' 'gdbm' 'dbus')
+replaces=(${_pkgname})
+optdepends=('gtk2: avahi-discover-standalone, bshell, bssh, bvnc, gtk2 bindings'
+ 'nss-mdns: NSS support for mDNS')
+makedepends=('intltool' 'gobject-introspection' 'gtk2' 'xmltoman' 'python2')
+backup=('etc/avahi/hosts'
+ 'etc/avahi/avahi-daemon.conf'
+ 'etc/avahi/services/ssh.service'
+ 'etc/avahi/services/sftp-ssh.service'
+ 'usr/lib/avahi/service-types.db'
+ 'usr/share/avahi/service-types')
+source=("http://www.avahi.org/download/avahi-${pkgver}.tar.gz")
+sha1sums=('7e05bd78572c9088b03b1207a0ad5aba38490684')
+
+conflicts=(${_pkgname} 'howl' 'mdnsresponder')
+provides=("${_pkgname}=${pkgver}" 'howl' 'mdnsresponder')
+
+install=install
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ sed '/^Libs:/s:$: -ldbus-1:' -i avahi-client.pc.in
+ sed 's:netdev:network:g' -i avahi-daemon/avahi-dbus.conf
+ sed 's:/sbin/resolvconf:/usr/sbin/resolvconf:g' -i */*.action
+ sed 's:-DG[^ ]*_DISABLE_DEPRECATED=1::g' -i avahi-ui/Makefile.*
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ export MOC_QT4=/usr/bin/moc-qt4
+ export PYTHON=/usr/bin/python2
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --sbindir=/usr/bin \
+ --disable-monodoc \
+ --disable-qt3 \
+ --disable-qt4 \
+ --disable-gtk3 \
+ --disable-pygtk \
+ --disable-python-dbus \
+ --disable-mono \
+ --disable-doxygen-doc \
+ --disable-doxygen-dot \
+ --disable-doxygen-xml \
+ --disable-doxygen-html \
+ --enable-compat-libdns_sd \
+ --enable-compat-howl \
+ --with-distro=archlinux \
+ --with-avahi-priv-access-group=network \
+ --with-autoipd-user=avahi \
+ --with-autoipd-group=avahi \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system \
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -fr "${pkgdir}"/etc/rc.d
+
+ # howl and mdnsresponder compatability
+ cd "${pkgdir}"/usr/include; ln -s avahi-compat-libdns_sd/dns_sd.h dns_sd.h; ln -s avahi-compat-howl howl
+ cd "${pkgdir}"/usr/lib/pkgconfig; ln -s avahi-compat-howl.pc howl.pc
+
+ # see FS#42638
+ ln avahi-daemon.service -s "${pkgdir}"/usr/lib/systemd/system/dbus-org.freedesktop.Avahi.service
+}
diff --git a/install b/install
new file mode 100644
index 000000000000..1db4754e33b5
--- /dev/null
+++ b/install
@@ -0,0 +1,22 @@
+post_install() {
+ getent group avahi &>/dev/null || groupadd -r -g 84 avahi >/dev/null
+ getent passwd avahi &>/dev/null || useradd -r -u 84 -g avahi -d / -s /bin/false -c avahi avahi >/dev/null
+
+ cat <<EOF
+==> The following daemons may be added to DAEMONS in /etc/rc.conf:
+==> avahi-daemon: the mdns responder, you probably want this.
+==> dbus needs to be running when you start it.
+==> avahi-dnsconfd: daemon used for peer-to-peer automatic dns
+==> configuration on dhcp-less networks.
+
+==> To use some of the client applications you will have to install python.
+==> In addition, pygtk is required for the graphical ones and
+==> twisted for avahi-bookmarks.
+EOF
+}
+
+post_remove() {
+ getent passwd avahi &>/dev/null && userdel avahi >/dev/null
+ getent group avahi &>/dev/null && groupdel avahi >/dev/null
+ true
+}