summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcfe0e5fa0a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = avarice-svn
+ pkgdesc = AVaRICE is a program for interfacing the Atmel JTAG ICE to GDB to allow users to debug their embedded AVR target.
+ pkgver = 20150713.350
+ pkgrel = 1
+ url = http://sourceforge.net/projects/avarice/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = svn
+ depends = libusb-compat
+ source = avarice-svn::svn+http://svn.code.sf.net/p/avarice/code/trunk
+ md5sums = SKIP
+
+pkgname = avarice-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9502a12b376f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Samuel Ace Winchenbach <swinchen at gmail dot com>
+pkgname=avarice-svn
+_pkgname=avarice
+pkgrel=1
+pkgver=20150713.350
+pkgdesc="AVaRICE is a program for interfacing the Atmel JTAG ICE to GDB to allow users to debug their embedded AVR target."
+arch=(i686 x86_64)
+url="http://sourceforge.net/projects/avarice/"
+license=('GPL')
+groups=()
+depends=(libusb-compat)
+makedepends=(svn)
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}::svn+http://svn.code.sf.net/p/avarice/code/trunk")
+noextract=()
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}/${_pkgname}"
+ ./Bootstrap
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/${_pkgname}"
+
+ make DESTDIR="$pkgdir/" install
+}
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ svn info | awk '/Revision/{r=$2}/Date/{gsub(/-/,"");d=$4}END{print d"."r}'
+}