summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD27
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 645f4e91a3dc..f5c8513309c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = avisynth-plugin-rawsource26-git
pkgdesc = Plugin for Avisynth: rawsource26 (GIT version)
- pkgver = 0.0.1.5.g1c0e215
+ pkgver = 1.3.2.0.g700e7e2
pkgrel = 1
url = https://github.com/Asd-g/RawSource_2.6x
arch = x86_64
license = custom
makedepends = git
makedepends = cmake
- depends = avisynthplus
+ makedepends = avisynthplus
+ depends = libavisynth.so
provides = avisynth-plugin-rawsource26
conflicts = avisynth-plugin-rawsource26
+ options = debug
source = rawsource26::git+https://github.com/Asd-g/RawSource_2.6x.git
sha256sums = SKIP
pkgname = avisynth-plugin-rawsource26-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f64636bed82c..c5106faea67e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,43 +2,42 @@
_plug=rawsource26
pkgname=avisynth-plugin-${_plug}-git
-pkgver=0.0.1.5.g1c0e215
+pkgver=1.3.2.0.g700e7e2
pkgrel=1
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/Asd-g/RawSource_2.6x'
license=('custom')
-depends=('avisynthplus')
+depends=('libavisynth.so')
makedepends=('git'
'cmake'
+ 'avisynthplus'
)
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/Asd-g/RawSource_2.6x.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-prepare() {
- mkdir -p build
-}
-
build() {
- cd build
+ cd "${_plug}"
+
+ CXXFLAGS+=" $(pkg-config --cflags avisynth)"
- cmake "../${_plug}/build" \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -S . -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake --build build
}
package(){
- install -Dm755 build/librawsourceplus.so "${pkgdir}/usr/lib/avisynth/librawsourceplus.so"
+ DESTDIR="${pkgdir}" cmake --install "${_plug}/build"
- install -Dm644 "${_plug}/src/RawSourcePlus.html" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/RawSourcePlus.html"
- install -Dm644 "${_plug}/src/readme.txt" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/readme.txt"
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"
}