summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b3b4e302344
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = avisynth-plugin-rawsource26-git
+ pkgdesc = Plugin for Avisynth: rawsource26 (GIT version)
+ pkgver = 0.0.1.5.g1c0e215
+ pkgrel = 1
+ url = https://github.com/Asd-g/RawSource_2.6x
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = avisynthplus
+ provides = avisynth-plugin-rawsource26
+ conflicts = avisynth-plugin-rawsource26
+ source = rawsource26::git+https://github.com/Asd-g/RawSource_2.6x.git
+ sha256sums = SKIP
+
+pkgname = avisynth-plugin-rawsource26-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67f383ece190
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=rawsource26
+pkgname=avisynth-plugin-${_plug}-git
+pkgver=0.0.1.5.g1c0e215
+pkgrel=1
+pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/Asd-g/RawSource_2.6x'
+license=('GPL')
+depends=('avisynthplus')
+makedepends=('git'
+ 'cmake'
+ )
+provides=("avisynth-plugin-${_plug}")
+conflicts=("avisynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/Asd-g/RawSource_2.6x.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ cmake "../${_plug}/build" \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+
+ make
+}
+
+package(){
+ install -Dm755 build/librawsourceplus.so "${pkgdir}/usr/lib/avisynth/librawsourceplus.so"
+
+# install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"
+}