summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0ec215a5c75..697943abf364 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = avisynth-plugin-removedirt-git
pkgdesc = Plugin for Avisynth: removedirt (GIT version)
- pkgver = v0.9.2.26.g2952af0
+ pkgver = 0.9.3.0.g46007dc
pkgrel = 1
url = https://github.com/pinterf/RemoveDirt
arch = x86_64
license = GPL
makedepends = git
makedepends = cmake
- depends = avisynthplus
+ makedepends = avisynthplus
+ depends = libavisynth.so
provides = avisynth-plugin-removedirt
conflicts = avisynth-plugin-removedirt
+ options = debug
source = removedirt::git+https://github.com/pinterf/RemoveDirt.git
sha256sums = SKIP
pkgname = avisynth-plugin-removedirt-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 25af061c0f38..9860709b97c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,45 @@
_plug=removedirt
pkgname=avisynth-plugin-${_plug}-git
-pkgver=v0.9.2.26.g2952af0
+pkgver=0.9.3.0.g46007dc
pkgrel=1
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/pinterf/RemoveDirt'
license=('GPL')
-depends=('avisynthplus')
+depends=('libavisynth.so')
makedepends=('git'
'cmake'
+ 'avisynthplus'
)
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/pinterf/RemoveDirt.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
prepare() {
- mkdir -p build
+ rm -fr "${_plug}/RemoveDirt/"{avs*,avi*}
}
build() {
- cd build
- cmake "../${_plug}" \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ CXXFLAGS=" $(pkg-config --cflags avisynth)"
- make
+ cmake -S "${_plug}" -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
+
+ cmake --build build
}
package(){
- make -C build DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install build
install -Dm644 "${_plug}/RemoveDirt/documentation/RemoveDirt.htm" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/RemoveDirt.htm"
}