summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0ec215a5c75..fb089be24bd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = avisynth-plugin-removedirt-git
pkgdesc = Plugin for Avisynth: removedirt (GIT version)
- pkgver = v0.9.2.26.g2952af0
+ pkgver = v0.9.3.0.g46007dc
pkgrel = 1
url = https://github.com/pinterf/RemoveDirt
arch = x86_64
@@ -14,4 +14,3 @@ pkgbase = avisynth-plugin-removedirt-git
sha256sums = SKIP
pkgname = avisynth-plugin-removedirt-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 25af061c0f38..43d813910f8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=removedirt
pkgname=avisynth-plugin-${_plug}-git
-pkgver=v0.9.2.26.g2952af0
+pkgver=v0.9.3.0.g46007dc
pkgrel=1
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -24,13 +24,17 @@ pkgver() {
prepare() {
mkdir -p build
+
+ rm -fr "${_plug}/RemoveDirt/"{avs*,avi*}
}
build() {
cd build
+ CXXFLAGS+=" $(pkg-config --cflags avisynth)"
+
cmake "../${_plug}" \
- -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
make