summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0ec215a5c75
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = avisynth-plugin-removedirt-git
+ pkgdesc = Plugin for Avisynth: removedirt (GIT version)
+ pkgver = v0.9.2.26.g2952af0
+ pkgrel = 1
+ url = https://github.com/pinterf/RemoveDirt
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = avisynthplus
+ provides = avisynth-plugin-removedirt
+ conflicts = avisynth-plugin-removedirt
+ source = removedirt::git+https://github.com/pinterf/RemoveDirt.git
+ sha256sums = SKIP
+
+pkgname = avisynth-plugin-removedirt-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25af061c0f38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=removedirt
+pkgname=avisynth-plugin-${_plug}-git
+pkgver=v0.9.2.26.g2952af0
+pkgrel=1
+pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/pinterf/RemoveDirt'
+license=('GPL')
+depends=('avisynthplus')
+makedepends=('git'
+ 'cmake'
+ )
+provides=("avisynth-plugin-${_plug}")
+conflicts=("avisynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/pinterf/RemoveDirt.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ cmake "../${_plug}" \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+
+ make
+}
+
+package(){
+ make -C build DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${_plug}/RemoveDirt/documentation/RemoveDirt.htm" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/RemoveDirt.htm"
+}