summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a53ceea1955f..1e1b86ad8e8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = avisynth-plugin-rgtools-git
pkgdesc = Plugin for Avisynth: rgtools (GIT version)
- pkgver = 1.1.0.g1311d1c
+ pkgver = 1.2.0.ga9cff29
pkgrel = 1
url = https://github.com/pinterf/RgTools
arch = x86_64
license = MIT
makedepends = git
makedepends = cmake
- depends = avisynthplus
+ makedepends = avisynthplus
+ depends = libavisynth.so
provides = avisynth-plugin-rgtools
conflicts = avisynth-plugin-rgtools
+ options = debug
source = rgtools::git+https://github.com/pinterf/RgTools.git
sha256sums = SKIP
pkgname = avisynth-plugin-rgtools-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e59796d8e16b..19800e5a54b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,41 @@
_plug=rgtools
pkgname=avisynth-plugin-${_plug}-git
-pkgver=1.1.0.g1311d1c
+pkgver=1.2.0.ga9cff29
pkgrel=1
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/pinterf/RgTools'
license=('MIT')
-depends=('avisynthplus')
+depends=('libavisynth.so')
makedepends=('git'
'cmake'
+ 'avisynthplus'
)
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/pinterf/RgTools.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-prepare() {
- mkdir -p build
-}
-
build() {
- cd build
- cmake "../${_plug}" \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ CXXFLAGS=" $(pkg-config --cflags avisynth)"
+
+ cmake -S "${_plug}" -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake --build build
}
package(){
- make -C build DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install build
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/${_plug}/README.md"
install -Dm644 "${_plug}/RgTools/documentation/RgTools.txt" "${pkgdir}/usr/share/doc/${_plug}/RgTools.txt"