summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD33
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f743bafedfbd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = avrm-max7221-git
+ pkgdesc = AVR library for the Maxis7221 LED driver.
+ pkgver = 0.0.3.r3.g987b94d
+ pkgrel = 1
+ url = https://github.com/nixpulvis/max7221
+ arch = any
+ makedepends = git
+ depends = avrm
+ optdepends = avrdude: for flashing code to devices
+ provides = avrm-max7221
+ conflicts = avrm-max7221
+ options = !strip
+ source = git+https://github.com/nixpulvis/max7221
+ md5sums = SKIP
+
+pkgname = avrm-max7221-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f33cbfd391f8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.xz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..591b350ee0d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Nathan Lilienthal <nathan@nixpulvis.com>
+pkgname=avrm-max7221-git
+pkgver=0.0.3.r3.g987b94d
+pkgrel=1
+pkgdesc="AVR library for the Maxis7221 LED driver."
+arch=('any')
+url="https://github.com/nixpulvis/max7221"
+depends=('avrm')
+optdepends=('avrdude: for flashing code to devices')
+makedepends=('git')
+provides=('avrm-max7221')
+conflicts=('avrm-max7221')
+options=('!strip')
+source=('git+https://github.com/nixpulvis/max7221')
+md5sums=('SKIP')
+
+pkgver() {
+ T="${pkgname%-git}"
+ cd "$srcdir/${T#avrm-}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ T="${pkgname%-git}"
+ cd "$srcdir/${T#avrm-}"
+ make
+}
+
+package() {
+ T="${pkgname%-git}"
+ cd "$srcdir/${T#avrm-}"
+ make PREFIX="$pkgdir/usr/avr/" install
+}