summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore26
-rw-r--r--PKGBUILD13
3 files changed, 37 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a7c4edc9865..97785d9698ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,19 @@
pkgbase = avro-c
pkgdesc = C bindings for Avro data serialization framework
- pkgver = 1.10.1
+ pkgver = 1.11.0
pkgrel = 1
url = https://github.com/apache/avro
arch = i686
arch = x86_64
license = Apache
makedepends = cmake
- makedepends = git
- makedepends = make
- makedepends = pkg-config
depends = jansson
depends = snappy
depends = xz
depends = zlib
optdepends = asciidoc: build with documentation
optdepends = source-highlight: add syntax highlighting to documentation
- source = avro-c-1.10.1.tar.gz::https://codeload.github.com/apache/avro/tar.gz/release-1.10.1
- sha256sums = 8fd1f850ce37e60835e6d8335c0027a959aaa316773da8a9660f7d33a66ac142
+ source = avro-c-1.11.0.tar.gz::https://github.com/apache/avro/archive/refs/tags/release-1.11.0.tar.gz
+ sha256sums = c205140e7936d552286ba7131122a34e522d66f601ee912f272109d801f89773
pkgname = avro-c
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6e01931f4be8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,26 @@
+### Vim ###
+# Swap
+[._]*.s[a-v][a-z]
+[._]*.sw[a-p]
+[._]s[a-rt-v][a-z]
+[._]ss[a-gi-z]
+[._]sw[a-p]
+
+# Session
+Session.vim
+
+# Temporary
+.netrwhist
+*~
+# Auto-generated tag files
+tags
+# Persistent undo
+[._]*.un~
+
+*.zip
+*.tar.gz
+*.xz
+pkg
+src
+tags.*
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
index beda509d1189..a4f1f7fad7ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,22 @@
-# Maintainer: Davide Depau <davide@depau.eu>
+# Maintainer: David Harrigan <dharrigan [@] gmail [dot] com>
+# Contributor: Davide Depau <davide@depau.eu>
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=avro-c
-pkgver=1.10.1
+pkgver=1.11.0
pkgrel=1
pkgdesc="C bindings for Avro data serialization framework"
arch=('i686' 'x86_64')
+makedepends=(cmake)
depends=('jansson' 'snappy' 'xz' 'zlib')
-makedepends=('cmake' 'git' 'make' 'pkg-config')
optdepends=('asciidoc: build with documentation'
'source-highlight: add syntax highlighting to documentation')
url="https://github.com/apache/avro"
license=('Apache')
-source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/apache/avro/tar.gz/release-$pkgver)
-sha256sums=('8fd1f850ce37e60835e6d8335c0027a959aaa316773da8a9660f7d33a66ac142')
+
+source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/release-${pkgver}.tar.gz)
+
+sha256sums=('c205140e7936d552286ba7131122a34e522d66f601ee912f272109d801f89773')
build() {
cd "$srcdir/avro-release-$pkgver/lang/c"