summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..184988c02d15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = avs2yuv-git
+ pkgdesc = A simple tool that can execute avisynth scripts. (GIT version)
+ pkgver = r20.7aa19f9
+ pkgrel = 1
+ url = https://github.com/DJATOM/avs2yuv
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = avisynthplus
+ provides = avs2yuv
+ conflicts = av2yuv
+ source = git+https://github.com/DJATOM/avs2yuv.git
+ sha256sums = SKIP
+
+pkgname = avs2yuv-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8590c00f9b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=avs2yuv-git
+pkgver=r20.7aa19f9
+pkgrel=1
+pkgdesc="A simple tool that can execute avisynth scripts. (GIT version)"
+arch=('x86_64')
+url='https://github.com/DJATOM/avs2yuv'
+license=('LGPL')
+depends=('avisynthplus')
+makedepends=('git')
+provides=('avs2yuv')
+conflicts=('av2yuv')
+source=('git+https://github.com/DJATOM/avs2yuv.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd avs2yuv
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+# echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ make -C avs2yuv
+}
+
+package(){
+ install -d "${pkgdir}/usr/bin"
+ make -C avs2yuv PREFIX="${pkgdir}/usr" install
+}