summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e9e8d6eb44e..ac280bb96a00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat May 21 17:02:32 UTC 2016
+# Thu May 26 17:46:50 UTC 2016
pkgbase = aws-cli-git
pkgdesc = Universal Command Line Interface for Amazon Web Services awscli
- pkgver = 1.10.32.r3816.g529ea24
+ pkgver = 1.10.33.r3825.g93a1a99
pkgrel = 1
url = https://github.com/aws/aws-cli
arch = any
@@ -12,9 +12,10 @@ pkgbase = aws-cli-git
makedepends = git
depends = python
depends = python-bcdoc
- depends = python-botocore>=1.4.22
+ depends = python-botocore>=1.4.23
depends = python-colorama>=0.2.5
depends = python-rsa>=3.2
+ depends = python-rsa<=3.5.0
depends = python-s3transfer>=0.0.1
depends = python-wheel>=0.24.0
depends = python-jmespath>=0.7.1
@@ -34,8 +35,8 @@ pkgbase = aws-cli-git
sha256sums = SKIP
pkgname = aws-cli-git
- provides = awscli=1.10.32
- provides = aws-cli=1.10.32
+ provides = awscli=1.10.33
+ provides = aws-cli=1.10.33
conflicts = python2-aws-cli
conflicts = python-aws-cli
conflicts = awscli
diff --git a/PKGBUILD b/PKGBUILD
index 8901272a4337..29ddf379aecb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,17 +24,17 @@ docutils>=0.10
nose==1.3.0
colorama>=0.2.5,<=0.3.3
mock==1.3.0
-rsa>=3.1.2,<=3.3.0
+rsa>=3.1.2,<=3.5.0
wheel==0.24.0
#setup.py
import awscli
-requires = ['botocore==1.4.22',
+requires = ['botocore==1.4.23',
'colorama>=0.2.5,<=0.3.3',
'docutils>=0.10',
- 'rsa>=3.1.2,<=3.3.0',
+ 'rsa>=3.1.2,<=3.5.0',
's3transfer==0.0.1']
"
}
@@ -50,7 +50,7 @@ else
pkgname="${_pyver}-${_pybase}-git"
_pyverother='python'
fi
-pkgver=1.10.32.r3816.g529ea24
+pkgver=1.10.33.r3825.g93a1a99
# Generally when this version changes, the version of botocore also changes
pkgrel=1
pkgdesc='Universal Command Line Interface for Amazon Web Services awscli'
@@ -59,9 +59,9 @@ url="https://github.com/aws/${_pybase}"
license=('Apache') # Apache License 2.0
_pydepends=( # See setup.py, README.rst, and requirements.txt for version dependencies
"${_pyver}-bcdoc" # AUR
- "${_pyver}-botocore>=1.4.22" # AUR == would make upgrades from AUR impossible. See below.
+ "${_pyver}-botocore>=1.4.23" # AUR == would make upgrades from AUR impossible. See below.
"${_pyver}-colorama>=0.2.5" #,"<=0.3.3"} # COM requested by phw
- "${_pyver}-rsa>=3.2" # ','<=3.3.0'} # COM requested by supermario & jsteel
+ "${_pyver}-rsa"{'>=3.2','<=3.5.0'} # COM
"${_pyver}-s3transfer>=0.0.1" # AUR
### These are from python-botocore