summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b291104a467..f389c980ffc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = aws-iam-authenticator-git
pkgdesc = A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster
- pkgver = v0.5.3.r16.g375e2c90
+ pkgver = 0.5.3.r16.g375e2c90
pkgrel = 1
url = https://github.com/kubernetes-sigs/aws-iam-authenticator
arch = x86_64
arch = aarch64
license = Apache
makedepends = go
+ makedepends = git
provides = aws-iam-authenticator
conflicts = aws-iam-authenticator
source = git+https://github.com/kubernetes-sigs/aws-iam-authenticator.git
diff --git a/PKGBUILD b/PKGBUILD
index 4c6cc478ba20..213639433218 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,17 @@
+# Maintainer:
+# Contributor: FabioLolix
+# Contributor: micwoj92
# Contributor: Chris Snell <chris.snell@gmail.com>
pkgname=aws-iam-authenticator-git
_pkgname=aws-iam-authenticator
-pkgver=v0.5.3.r16.g375e2c90
+pkgver=0.5.3.r16.g375e2c90
pkgrel=1
pkgdesc='A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster'
arch=('x86_64' 'aarch64')
url='https://github.com/kubernetes-sigs/aws-iam-authenticator'
license=('Apache')
-makedepends=('go')
+makedepends=('go' git)
conflicts=('aws-iam-authenticator')
provides=('aws-iam-authenticator')
source=('git+https://github.com/kubernetes-sigs/aws-iam-authenticator.git')
@@ -16,17 +19,18 @@ sha512sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- ( set -o pipefail
- git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "$srcdir/$_pkgname"
+
go build \
- --trimpath \
- --ldflags "-X main.version=$pkgver" \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\"" \
./cmd/aws-iam-authenticator
}