summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 281ce1f11fb1..e415e8d86697 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,9 +5,8 @@ pkgbase = awsenv-bin
url = https://github.com/soniah/awsenv
arch = x86_64
license = MIT
- makedepends = go-pie
provides = awsenv
- source = https://github.com/soniah/awsenv/releases/download/v0.0.7/awsenv_0.0.7_linux_amd64.tar.gz
+ source = awsenv-bin-0.0.7.tar.gz::https://github.com/soniah/awsenv/releases/download/v0.0.7/awsenv_0.0.7_linux_amd64.tar.gz
sha256sums = c86136ac89d995e1bb08a9bb590308e0d705b61369c257444cbd58f0fd4b2ce0
pkgname = awsenv-bin
diff --git a/PKGBUILD b/PKGBUILD
index c007ef6a5b7b..28c144063f56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,15 +8,14 @@ arch=('x86_64')
url='https://github.com/soniah/awsenv'
license=('MIT')
provides=("${pkgname%-bin}")
-makedepends=('go-pie')
-source=("${url}/releases/download/v${pkgver}/awsenv_${pkgver}_linux_amd64.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/awsenv_${pkgver}_linux_amd64.tar.gz")
sha256sums=('c86136ac89d995e1bb08a9bb590308e0d705b61369c257444cbd58f0fd4b2ce0')
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}_${pkgver}_linux_amd64/${pkgname%-bin}" \
-t "${pkgdir}/usr/bin/"
install -Dm644 "${srcdir}/${pkgname%-bin}_${pkgver}_linux_amd64/LICENSE" \
- "${pkgdir}/usr/share/licenses/${pkgname%-bin}/LICENSE"
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 "${srcdir}/${pkgname%-bin}_${pkgver}_linux_amd64/README.md" \
-t "${pkgdir}/usr/share/doc/${pkgname%-bin}"
} \ No newline at end of file