summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
-rw-r--r--ax25.patch22
3 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a838190c9f31..358fcd037cf0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Mon Oct 14 12:53:19 UTC 2019
pkgbase = ax25-tools
pkgdesc = The network tools to configure hamradio interfaces and some of the hamradio specific network daemons
- pkgver = 0.0.10_rc4
+ pkgver = 0.0.10_rc5
pkgrel = 4
url = http://www.linux-ax25.org
arch = i686
@@ -15,12 +17,10 @@ pkgbase = ax25-tools
backup = etc/ax25/rip98d.conf
backup = etc/ax25/rxecho.conf
backup = etc/ax25/ttylinkd.conf
- source = http://http.debian.net/debian/pool/main/a/ax25-tools/ax25-tools_0.0.10-rc4.orig.tar.gz
+ source = http://www.linux-ax25.org/pub/ax25-tools/ax25-tools-0.0.10-rc5.tar.gz
source = ax25.patch
- sha1sums = c98b7071302e7c9947cbab47c88bf1c1dd4132b0
- sha1sums = f3dfdfce9a795baef7f93d62d92441e81b96a83e
- sha256sums = d36ad473f8261ea91dbef105d7493890774f2d1d03a485b86ddd23cbed597e20
- sha256sums = 0b954ed9b717670e18b138030c8ed73af740357c50e1527e91d0ee3d12a12079
+ md5sums = b8cf1495820c445013c3776babcd057d
+ md5sums = 6b51a5b1f58e7238fa223e8e439ae8bc
pkgname = ax25-tools
diff --git a/PKGBUILD b/PKGBUILD
index b2d2a2dbec51..c054ed813c81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Gordon JC Pearce <gordon@gjcp.net>
# From the comment by Chuck Atkins <chuckatkins@gmail.com>
pkgname=ax25-tools
-pkgver=0.0.10_rc4
+pkgver=0.0.10_rc5
_pkgver=${pkgver//_/-}
pkgrel=4
pkgdesc="The network tools to configure hamradio interfaces and some of the hamradio specific network daemons"
@@ -11,7 +11,7 @@ license=('GPL2')
depends=('libax25')
makedepends=('make')
source=(
- "http://http.debian.net/debian/pool/main/a/${pkgname}/${pkgname}_${_pkgver}.orig.tar.gz"
+ "http://www.linux-ax25.org/pub/${pkgname}/${pkgname}-${_pkgver}.tar.gz"
'ax25.patch'
)
backup=('etc/ax25/ax25.profile'
@@ -38,7 +38,6 @@ package() {
make install DESTDIR=$pkgdir || return 1
make installconf DESTDIR=$pkgdir || return 1
}
-sha1sums=('c98b7071302e7c9947cbab47c88bf1c1dd4132b0'
- 'f3dfdfce9a795baef7f93d62d92441e81b96a83e')
-sha256sums=('d36ad473f8261ea91dbef105d7493890774f2d1d03a485b86ddd23cbed597e20'
- '0b954ed9b717670e18b138030c8ed73af740357c50e1527e91d0ee3d12a12079')
+
+md5sums=('b8cf1495820c445013c3776babcd057d'
+ '6b51a5b1f58e7238fa223e8e439ae8bc')
diff --git a/ax25.patch b/ax25.patch
index 359d71190721..af0cab63115d 100644
--- a/ax25.patch
+++ b/ax25.patch
@@ -1,6 +1,16 @@
--- ax25/ax25d.c
+++ ax25/ax25d.c
-@@ -307,6 +307,17 @@ int main(int argc, char *argv[])
+@@ -260,7 +260,8 @@ static void SignalTERM(int code)
+ syslog(LOG_INFO, "terminating on SIGTERM\n");
+ closelog();
+ }
+-
++ // FIXME - hardcoded path
++ unlink("/var/run/ax25d.pid");
+ exit(0);
+ }
+
+@@ -1083,6 +1084,17 @@ int main(int argc, char *argv[])
syslog(LOG_INFO, "starting");
}
@@ -18,16 +28,6 @@
act.sa_handler = SignalHUP;
sigemptyset(&act.sa_mask);
act.sa_flags = 0;
-@@ -643,7 +654,8 @@ static void SignalTERM(int code)
- syslog(LOG_INFO, "terminating on SIGTERM\n");
- closelog();
- }
--
-+ // FIXME - hardcoded path
-+ unlink("/var/run/ax25d.pid");
- exit(0);
- }
-
--- ax25/mheardd.c
+++ ax25/mheardd.c
@@ -98,7 +98,7 @@ static void terminate(int sig)