summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..719523282838
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = axosnake-git
+ pkgdesc = a snake game written in rust with quicksilver
+ pkgver = r67.6caf3a1
+ pkgrel = 1
+ url = https://gitlab.com/nycex/axosnake
+ arch = any
+ license = MIT
+ depends = rust
+ source = git+https://gitlab.com/nycex/axosnake
+ sha256sums = SKIP
+
+pkgname = axosnake-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b27964334c29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: nycex <nycex@protonmail.com>
+_pkgbasename=axosnake
+pkgname=$_pkgbasename-git
+pkgrel=1
+pkgver=r67.6caf3a1
+pkgdesc="a snake game written in rust with quicksilver"
+arch=('any')
+url="https://gitlab.com/nycex/$_pkgbasename"
+license=('MIT')
+depends=('rust')
+source=(git+https://gitlab.com/nycex/${_pkgbasename})
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgbasename}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgbasename}"
+ cargo build --release
+}
+
+package() {
+ cd "${srcdir}/${_pkgbasename}"
+
+ install -D -m755 target/release/$_pkgbasename "${pkgdir}/usr/bin/$_pkgbasename"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/license/$_pkgbasename/LICENSE"
+}