summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO36
-rw-r--r--0001-Make-systemd-optional.-If-systemd-is-not-available-a.patch58
-rw-r--r--PKGBUILD34
3 files changed, 128 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..812645ba0ebd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = ayatana-indicator-application
+ pkgdesc = Ayatana Application Indicators
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = https://github.com/AyatanaIndicators
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = GPL3
+ license = LGPL2.1
+ license = LGPL3
+ makedepends = mate-common
+ makedepends = xorg-server-xvfb
+ makedepends = glib2
+ makedepends = gtk3
+ makedepends = dbus-glib
+ makedepends = json-glib
+ makedepends = intltool
+ makedepends = libayatana-appindicator-gtk3
+ makedepends = libayatana-indicator-gtk3
+ makedepends = libdbusmenu-glib
+ makedepends = libdbusmenu-gtk3
+ makedepends = systemd
+ depends = libayatana-appindicator-gtk3
+ depends = libayatana-indicator-gtk3
+ depends = dbus-glib
+ depends = libdbusmenu-gtk3
+ depends = glib2
+ depends = gtk3
+ depends = pango
+ options = !emptydirs
+ source = http://releases.ayatana-indicators.org/source/ayatana-indicator-application/ayatana-indicator-application-0.5.2.tar.gz
+ md5sums = 15a5d17de624004cc814cc5d7b895478
+
+pkgname = ayatana-indicator-application
+
diff --git a/0001-Make-systemd-optional.-If-systemd-is-not-available-a.patch b/0001-Make-systemd-optional.-If-systemd-is-not-available-a.patch
new file mode 100644
index 000000000000..18521f204b05
--- /dev/null
+++ b/0001-Make-systemd-optional.-If-systemd-is-not-available-a.patch
@@ -0,0 +1,58 @@
+From 2c6c3adc1871735f72eb48bda3fdf600d79b6d0a Mon Sep 17 00:00:00 2001
+From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
+Date: Fri, 6 Oct 2017 11:53:45 +0200
+Subject: [PATCH 1/2] Make systemd optional. If systemd is not available at
+ build-time, the creation of the .service file is omitted.
+
+---
+ configure.ac | 14 ++++++++++++--
+ data/Makefile.am | 4 +++-
+ 2 files changed, 15 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6bbb300..ac4b7c4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -50,8 +50,18 @@ PKG_CHECK_MODULES(INDICATOR, glib-2.0 >= $GLIB_REQUIRED_VERSION
+ dbusmenu-gtk3-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION)
+ PKG_CHECK_MODULES(APPINDICATOR, ayatana-appindicator3-0.1 >= $LIBAPPINDICATOR_REQUIRED_VERSION)
+
+-SYSTEMD_USERDIR=`$PKG_CONFIG --variable=systemduserunitdir systemd`
+-AC_SUBST(SYSTEMD_USERDIR)
++#########################
++# Check for systemd
++#########################
++PKG_CHECK_MODULES(SYSTEMD, systemd,
++ [has_systemd=yes],
++ []
++)
++if test "x$has_systemd" = "xyes"; then
++ SYSTEMD_USERDIR=`$PKG_CONFIG --variable=systemduserunitdir systemd`
++ AC_SUBST(SYSTEMD_USERDIR)
++ AC_DEFINE(HAVE_SYSTEMD, 1, [create ayatana-indicator-application.service for systemd])
++fi
+
+ ###########################
+ # gcov coverage reporting
+diff --git a/data/Makefile.am b/data/Makefile.am
+index f7cc652..96abc17 100644
+--- a/data/Makefile.am
++++ b/data/Makefile.am
+@@ -16,11 +16,13 @@ xdg_autostart_DATA = ayatana-indicator-application.desktop
+ overridedir = $(pkgdatadir)
+ override_DATA = ordering-override.keyfile
+
++#if defined(HAVE_SYSTEMD)
+ %.service: %.service.in
+ $(AM_V_GEN) sed -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+-
++
+ systemddir = $(SYSTEMD_USERDIR)
+ systemd_DATA = ayatana-indicator-application.service
++#endif
+
+ upstartsystemdoverridedir = $(datadir)/upstart/systemd-session/upstart
+ upstartsystemdoverride_DATA = ayatana-indicator-application.override
+--
+2.11.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87ee20694ab5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Robert Tari <robert at tari dot in>
+
+pkgname="ayatana-indicator-application"
+pkgver="0.5.2"
+pkgrel="1"
+pkgdesc="Ayatana Application Indicators"
+arch=("i686" "x86_64")
+url="https://github.com/AyatanaIndicators"
+license=("GPL2" "GPL3" "LGPL2.1" "LGPL3")
+depends=("libayatana-appindicator-gtk3" "libayatana-indicator-gtk3" "dbus-glib" "libdbusmenu-gtk3" "glib2" "gtk3" "pango")
+makedepends=("mate-common" "xorg-server-xvfb" "glib2" "gtk3" "dbus-glib" "json-glib" "intltool" "libayatana-appindicator-gtk3" "libayatana-indicator-gtk3" "libdbusmenu-glib" "libdbusmenu-gtk3" "systemd")
+source=("http://releases.ayatana-indicators.org/source/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=("15a5d17de624004cc814cc5d7b895478")
+options=("!emptydirs")
+
+prepare()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -Np1 -i ../../0001-Make-systemd-optional.-If-systemd-is-not-available-a.patch
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --libexecdir=/usr/lib
+ make
+}
+
+package()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}