summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD30
-rwxr-xr-xaz2
-rw-r--r--install.response8
5 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16bd2d8132af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = azure-cli
+ pkgdesc = Command-line tools for Azure.
+ pkgver = 2.0.77
+ pkgrel = 1
+ url = https://github.com/Azure/azure-cli
+ arch = any
+ license = MIT
+ makedepends = python
+ conflicts = python-azure-cli
+ source = https://azurecliprod.blob.core.windows.net/install.py
+ source = install.response
+ source = az
+ sha256sums = 9dc76481771bb2e219217187a1331a85a426e685d4070867a42d5825956ee512
+ sha256sums = 7c05e9915a52fb72fa8d1c498b173c42457d669351313eaddccf43f86ed0e0ec
+ sha256sums = 990f70efec828c1e1f3f57748fc6e40f9705f2223dc96683e8e29d118daac116
+
+pkgname = azure-cli
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f6b4a8512010
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# Created by https://www.gitignore.io/api/archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40e7dd63c3b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: pallxk <aur@pallxk.com>
+# https://docs.microsoft.com/en-us/cli/azure/install-azure-cli-linux
+
+pkgname=azure-cli
+pkgver=2.0.77
+pkgrel=1
+pkgdesc="Command-line tools for Azure."
+arch=('any')
+url="https://github.com/Azure/azure-cli"
+license=('MIT')
+makedepends=("python")
+conflicts=("python-azure-cli")
+source=("https://azurecliprod.blob.core.windows.net/install.py"
+ "install.response"
+ "az")
+sha256sums=("9dc76481771bb2e219217187a1331a85a426e685d4070867a42d5825956ee512"
+ "7c05e9915a52fb72fa8d1c498b173c42457d669351313eaddccf43f86ed0e0ec"
+ "990f70efec828c1e1f3f57748fc6e40f9705f2223dc96683e8e29d118daac116")
+
+build() {
+ grep -v -E '^===>|^$' install.response | python "$srcdir/install.py"
+}
+
+package() {
+ mkdir "$pkgdir/opt"
+ cp -r azure-cli "$pkgdir/opt"
+
+ mkdir -p "$pkgdir/usr/bin"
+ cp az "$pkgdir/usr/bin"
+}
diff --git a/az b/az
new file mode 100755
index 000000000000..575f87a0a3b0
--- /dev/null
+++ b/az
@@ -0,0 +1,2 @@
+#!/usr/bin/env bash
+/opt/azure-cli/bin/python -m azure.cli "$@"
diff --git a/install.response b/install.response
new file mode 100644
index 000000000000..346b205a8431
--- /dev/null
+++ b/install.response
@@ -0,0 +1,8 @@
+===> In what directory would you like to place the install? (leave blank to use '~/lib/azure-cli'):
+./azure-cli
+
+===> In what directory would you like to place the 'az' executable? (leave blank to use '~/bin'):
+./bin
+
+===> Modify profile to update your $PATH and enable shell/tab completion now? (Y/n):
+n