aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore5
-rw-r--r--50-kinect-azure.rules2
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD44
-rw-r--r--README.md10
6 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..064270b71771
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = azure-kinect-sensor-sdk-git
+ pkgdesc = A cross platform user mode SDK to read data from Azure Kinect devices.
+ pkgver = v1.2.0.beta.1.r4.4b37ca7d
+ pkgrel = 1
+ url = https://github.com/microsoft/Azure-Kinect-Sensor-SDK
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ makedepends = ninja
+ depends = libsoundio
+ depends = libxinerama
+ depends = libxrandr
+ depends = libglvnd
+ depends = libxcursor
+ depends = systemd-libs
+ provides = azure-kinect-sensor-sdk
+ conflicts = azure-kinect-sensor-sdk
+ source = azure-kinect-sensor-sdk::git+https://github.com/microsoft/Azure-Kinect-Sensor-SDK
+ md5sums = SKIP
+
+pkgname = azure-kinect-sensor-sdk-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..37f1e7889865
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+Azure-Kinect-Sensor-SDK/
+azure-kinect-sensor-sdk/
+*.tar.xz
diff --git a/50-kinect-azure.rules b/50-kinect-azure.rules
new file mode 100644
index 000000000000..e1d2e05a344a
--- /dev/null
+++ b/50-kinect-azure.rules
@@ -0,0 +1,2 @@
+# /etc/udev/rules.d/50-kinect-azure.rules
+SUBSYSTEM=="usb", ATTR{idVendor}=="045e", TAG+="uaccess"
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..2806143ae2ba
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2019 Ryan Jacobs
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9192ce5f6f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Ryan Jacobs <ryan@rmj.us>
+pkgname=azure-kinect-sensor-sdk-git
+pkgver=v1.2.0.beta.1.r4.4b37ca7d
+pkgrel=1
+pkgdesc="A cross platform user mode SDK to read data from Azure Kinect devices."
+arch=("x86_64")
+url="https://github.com/microsoft/Azure-Kinect-Sensor-SDK"
+license=("MIT")
+depends=("libsoundio" "libxinerama" "libxrandr" "libglvnd" "libxcursor" "systemd-libs")
+makedepends=("git" "cmake" "ninja")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("azure-kinect-sensor-sdk::git+https://github.com/microsoft/Azure-Kinect-Sensor-SDK")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cp -v ../50-kinect-azure.rules .
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir -p build
+ cd build
+ cmake ..
+ make -j$(nproc)
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+
+ # make install
+ cd build
+ make DESTDIR="$pkgdir/" install
+ cd ../../
+
+ # install udev rule
+ mkdir -p "$pkgdir/udev/rules.d"
+ cp -v 50-kinect-azure.rules "$pkgdir/udev/rules.d/"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..413b530dc900
--- /dev/null
+++ b/README.md
@@ -0,0 +1,10 @@
+# AUR-azure-kinect-sensor-sdk
+
+Created in response to
+https://github.com/microsoft/Azure-Kinect-Sensor-SDK/issues/631
+
+Make sure to modify your `LD_LIBRARY_PATH`.
+
+```console
+$ export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/local/lib64"
+```