summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
-rw-r--r--sqlops.desktop18
3 files changed, 37 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b995bdd0cca..be8675d18e26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sqlops
pkgdesc = SQL Operations Studio is a data management tool that enables you to work with SQL Server, Azure SQL DB and SQL DW from Windows, macOS and Linux.
- pkgver = 0.25.4
+ pkgver = 0.26.3
pkgrel = 1
url = https://github.com/Microsoft/sqlopsstudio
arch = x86_64
@@ -22,8 +22,10 @@ pkgbase = sqlops
depends = curl
optdepends = krb5: Windows authentication support
options = staticlibs
- source = https://github.com/Microsoft/sqlopsstudio/releases/download/0.25.4/sqlops-linux-0.25.4.tar.gz
- sha256sums = af259da7df87ddd376296aca5a6b174289e02d2737d248ad28cd8a7123316562
+ source = https://github.com/Microsoft/sqlopsstudio/releases/download/0.26.1/sqlops-linux-0.26.3.tar.gz
+ source = sqlops.desktop
+ sha256sums = f8387cb34ad1f15e86f3ca9e8392a1a64bbdef4da25d505e1e4779add4e5a0a8
+ sha256sums = b5ad95bef9b56aba179c642e0edac04c32aa8cb3c4c0428cf0257119995e1dc2
pkgname = sqlops
diff --git a/PKGBUILD b/PKGBUILD
index a9c96e6c42a9..8fe94a4b963f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: William Turner <willtur.will@gmail.com>
pkgname=sqlops
-pkgver=0.25.4
+pkgver=0.26.3
pkgrel=1
pkgdesc="SQL Operations Studio is a data management tool that enables you to work with SQL Server, Azure SQL DB and SQL DW from Windows, macOS and Linux."
arch=('x86_64')
@@ -9,16 +9,22 @@ license=('custom: microsoft')
depends=('fontconfig' 'libxtst' 'gtk2' 'python' 'cairo' 'alsa-lib' 'nss' 'gcc-libs' 'glibc' 'libxss' 'gconf' 'libxkbfile' 'libunwind' 'libsecret' 'curl')
optdepends=('krb5: Windows authentication support')
options=('staticlibs')
-source=("https://github.com/Microsoft/sqlopsstudio/releases/download/${pkgver}/sqlops-linux-${pkgver}.tar.gz")
-sha256sums=('af259da7df87ddd376296aca5a6b174289e02d2737d248ad28cd8a7123316562')
+source=("https://github.com/Microsoft/sqlopsstudio/releases/download/0.26.1/sqlops-linux-0.26.3.tar.gz"
+ 'sqlops.desktop')
+sha256sums=('f8387cb34ad1f15e86f3ca9e8392a1a64bbdef4da25d505e1e4779add4e5a0a8'
+ 'b5ad95bef9b56aba179c642e0edac04c32aa8cb3c4c0428cf0257119995e1dc2')
package() {
- install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d "${pkgdir}/usr/share/${pkgname}"
+ cp -r "${srcdir}/sqlops-linux-x64/"* "${pkgdir}/usr/share/${pkgname}"
+
+ # Symlink the startup script in /usr/bin
install -d "${pkgdir}/usr/bin"
- install -d "${pkgdir}/opt/${pkgname}"
+ ln -s "/usr/share/${pkgname}/bin/sqlops" "${pkgdir}/usr/bin/sqlops"
- install -m644 "${srcdir}/sqlops-linux-x64/resources/app/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # Add the .desktop file
+ install -D -m644 "${srcdir}/sqlops.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- cp -r "${srcdir}/sqlops-linux-x64/"* "${pkgdir}/opt/${pkgname}"
- ln -s /opt/${pkgname}/bin/sqlops "${pkgdir}/usr/bin/sqlops"
+ # Install the license file
+ install -D -m644 "${srcdir}/sqlops-linux-x64/resources/app/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/sqlops.desktop b/sqlops.desktop
new file mode 100644
index 000000000000..70a99b2b2e90
--- /dev/null
+++ b/sqlops.desktop
@@ -0,0 +1,18 @@
+[Desktop Entry]
+Name=SQL Operations Studio
+Comment=SQL Operations Studio
+GenericName=Text Editor
+Exec=/usr/bin/sqlops --unity-launch %F
+Icon=/usr/share/sqlops/resources/app/resources/linux/code.png
+Type=Application
+StartupNotify=true
+StartupWMClass=sqlops
+Categories=Utility;TextEditor;Development;IDE;
+MimeType=text/plain;inode/directory;
+Actions=new-empty-window;
+Keywords=sqlops;
+
+[Desktop Action new-empty-window]
+Name=New Empty Window
+Exec=/usr/share/sqlops/sqlops --new-window %F
+Icon=sqlops