summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD32
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba803aba0966
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = b00merang-haiku-git
+ pkgdesc = GTK theme based on the appearance of the open source operating system Haiku, the successor to BeOS.
+ pkgver = r31.9fa6424
+ pkgrel = 1
+ url = https://github.com/B00merang-Project/Haiku
+ arch = any
+ license = GPL3
+ makedepends = git
+ source = b00merang-haiku-git::git+https://github.com/B00merang-Project/Haiku.git
+ sha256sums = SKIP
+
+pkgname = b00merang-haiku-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e8e882778e01
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e52b3445167e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Cezary Drożak <czarek at drozak dot net>
+
+pkgname=b00merang-haiku-git
+pkgver=r31.9fa6424
+pkgrel=1
+pkgdesc='GTK theme based on the appearance of the open source operating system Haiku, the successor to BeOS.'
+arch=('any')
+url='https://github.com/B00merang-Project/Haiku'
+license=('GPL3')
+makedepends=('git')
+source=("${pkgname}::git+$url.git")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "$pkgname"
+
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$pkgname"
+ local dest="$pkgdir"/usr/share/themes/'Haiku'
+
+ install -d "$dest"
+ cp -r * "$dest"
+}
+
+# vim: ts=4 sw=4 ft=sh