summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6dada39da04e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = babel
+ pkgdesc = Babel randomly generates character strings based on context free grammars.
+ pkgver = 2.0
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = ghc=8.0.1
+ depends = haskell-random
+ depends = haskell-parsec
+ source = babel-2.0.tar.gz::https://github.com/quytelda/babel/archive/v2.0.tar.gz
+ md5sums = 788494cc53283f35617db241bdd2ab08
+
+pkgname = babel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83752759570b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Quytelda Kahja <quytelda at tamalin dot org>
+pkgname=babel
+pkgver=2.0
+pkgrel=1
+pkgdesc="Babel randomly generates character strings based on context free grammars."
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('ghc=8.0.1' 'haskell-random' 'haskell-parsec')
+source=("$pkgname-${pkgver//_/-}.tar.gz::https://github.com/quytelda/babel/archive/v${pkgver//_/-}.tar.gz")
+md5sums=('788494cc53283f35617db241bdd2ab08')
+
+build() {
+ cd "$srcdir/$pkgname-${pkgver//_/-}"
+ runhaskell Setup configure --prefix=/usr
+ runhaskell Setup build
+}
+
+package() {
+ cd "$srcdir/$pkgname-${pkgver//_/-}"
+ runhaskell Setup copy --destdir="$pkgdir/"
+} \ No newline at end of file