summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99462c9cb918..3374830ccaf4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = backend-ai-desktop-bin
- pkgdesc = Backend.AI Web UI provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics.
- pkgver = 23.09.5
+ pkgdesc = Provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics.
+ pkgver = 23.09.7
pkgrel = 1
url = https://www.backend.ai/
arch = aarch64
@@ -10,15 +10,15 @@ pkgbase = backend-ai-desktop-bin
makedepends = gendesk
depends = electron26
depends = hicolor-icon-theme
- provides = backend-ai-desktop=23.09.5
+ provides = backend-ai-desktop=23.09.7
conflicts = backend-ai-desktop
conflicts = backend.ai
conflicts = backend.ai-desktop
source = backend-ai-desktop.sh
sha256sums = 27e8e3578355522309a16c4812b43e11f4632196060696b2705a8fca9a65c3f3
- source_aarch64 = backend-ai-desktop-23.09.5-aarch64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.5/backend.ai-desktop-23.09.5-linux-arm64.zip
- sha256sums_aarch64 = 4b129cfbd43987858652eb352c209ca56f6c0bb7c25ff361eb654ab7d1b97fbe
- source_x86_64 = backend-ai-desktop-23.09.5-x86_64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.5/backend.ai-desktop-23.09.5-linux-x64.zip
- sha256sums_x86_64 = 4a5f06a66b5a91a0a3dd84e641c34e6fbce655ff20cc102217ea45a519d13140
+ source_aarch64 = backend-ai-desktop-23.09.7-aarch64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.7/backend.ai-desktop-23.09.7-linux-arm64.zip
+ sha256sums_aarch64 = 48bba4f5f37a0cd1e927aba67bf709593fffc0fb5aa1104b5eca4d2c2f3554e2
+ source_x86_64 = backend-ai-desktop-23.09.7-x86_64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.7/backend.ai-desktop-23.09.7-linux-x64.zip
+ sha256sums_x86_64 = 6aba02d6302e6c4743529136a1e26ce5c2c734d5cf4f1da123d4a2976a990810
pkgname = backend-ai-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6433bcb6f5ec..78db4323315e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
_pkgname=backend.ai-desktop
pkgname="${_pkgname//./-}-bin"
_appname="Backend.AI Desktop"
-pkgver=23.09.5
+pkgver=23.09.7
pkgrel=1
-pkgdesc="Backend.AI Web UI provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics."
+pkgdesc="Provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics."
arch=(
"aarch64"
"x86_64"
)
url="https://www.backend.ai/"
-_githuburl="https://github.com/lablup/backend.ai-webui"
+_ghurl="https://github.com/lablup/backend.ai-webui"
license=('LGPL3')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=(
@@ -26,12 +26,12 @@ makedepends=(
'asar'
'gendesk'
)
-source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${_githuburl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-arm64.zip")
-source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${_githuburl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-x64.zip")
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-arm64.zip")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-x64.zip")
source=("${pkgname%-bin}.sh")
sha256sums=('27e8e3578355522309a16c4812b43e11f4632196060696b2705a8fca9a65c3f3')
-sha256sums_aarch64=('4b129cfbd43987858652eb352c209ca56f6c0bb7c25ff361eb654ab7d1b97fbe')
-sha256sums_x86_64=('4a5f06a66b5a91a0a3dd84e641c34e6fbce655ff20cc102217ea45a519d13140')
+sha256sums_aarch64=('48bba4f5f37a0cd1e927aba67bf709593fffc0fb5aa1104b5eca4d2c2f3554e2')
+sha256sums_x86_64=('6aba02d6302e6c4743529136a1e26ce5c2c734d5cf4f1da123d4a2976a990810')
build() {
gendesk -q -f -n --pkgname="${_pkgname//./-}-bin" --categories "Development" --name "${pkgname%-bin}" --exec "${pkgname%-bin}"
asar e "${srcdir}/${_appname}-linux-"*/resources/app.asar "${srcdir}/app.asar.unpacked"