summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD12
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87294262a33d..5bdd12bcc3dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
pkgbase = backend-ai-desktop-bin
pkgdesc = Provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics.
- pkgver = 23.09.9
- pkgrel = 2
+ pkgver = 23.09.10
+ pkgrel = 1
url = https://www.backend.ai/
arch = aarch64
arch = x86_64
license = LGPL-3.0-only
makedepends = gendesk
- depends = electron26
- provides = backend-ai-desktop=23.09.9
+ depends = electron29
+ provides = backend-ai-desktop=23.09.10
conflicts = backend-ai-desktop
conflicts = backend.ai
conflicts = backend.ai-desktop
- source = backend-ai-desktop-23.09.9.png::https://raw.githubusercontent.com/lablup/backend.ai-webui/v23.09.9/manifest/backend-ai.iconset/icon_512x512%401x.png
+ source = backend-ai-desktop-23.09.10.png::https://raw.githubusercontent.com/lablup/backend.ai-webui/v23.09.10/manifest/backend-ai.iconset/icon_512x512%401x.png
source = backend-ai-desktop.sh
sha256sums = c54209c33c387908bfaae40a9c5f6c96bacaa52684f2546068e2b4441f4a53b3
sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
- source_aarch64 = backend-ai-desktop-23.09.9-aarch64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.9/backend.ai-desktop-23.09.9-linux-arm64.zip
- sha256sums_aarch64 = 1f1a905b2501d11a554c7a45000f9b0de6adf5925a4e648bebcf70452fe7ad9f
- source_x86_64 = backend-ai-desktop-23.09.9-x86_64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.9/backend.ai-desktop-23.09.9-linux-x64.zip
- sha256sums_x86_64 = 8c6474d76516aac0bd54635b2331ecc3f2983f4f4a3f5512f3fbff8788a2bb2e
+ source_aarch64 = backend-ai-desktop-23.09.10-aarch64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.10/backend.ai-desktop-23.09.10-linux-arm64.zip
+ sha256sums_aarch64 = 5db7712dba826cd7486b819a6da606151f12225c8e6ce666dd7ff7f47cea3352
+ source_x86_64 = backend-ai-desktop-23.09.10-x86_64.zip::https://github.com/lablup/backend.ai-webui/releases/download/v23.09.10/backend.ai-desktop-23.09.10-linux-x64.zip
+ sha256sums_x86_64 = aa2ac499547f41fa2719cea81983c52a22150bae987fc1672ebbfa9c90323106
pkgname = backend-ai-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
index 3637374bb58a..75839cbbf5cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
_pkgname=backend.ai-desktop
pkgname="${_pkgname//./-}-bin"
_appname="Backend.AI Desktop"
-pkgver=23.09.9
-_electronversion=26
-pkgrel=2
+pkgver=23.09.10
+_electronversion=29
+pkgrel=1
pkgdesc="Provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics."
arch=(
"aarch64"
@@ -33,13 +33,13 @@ source=(
)
sha256sums=('c54209c33c387908bfaae40a9c5f6c96bacaa52684f2546068e2b4441f4a53b3'
'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
-sha256sums_aarch64=('1f1a905b2501d11a554c7a45000f9b0de6adf5925a4e648bebcf70452fe7ad9f')
-sha256sums_x86_64=('8c6474d76516aac0bd54635b2331ecc3f2983f4f4a3f5512f3fbff8788a2bb2e')
+sha256sums_aarch64=('5db7712dba826cd7486b819a6da606151f12225c8e6ce666dd7ff7f47cea3352')
+sha256sums_x86_64=('aa2ac499547f41fa2719cea81983c52a22150bae987fc1672ebbfa9c90323106')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
- -e "s|@options@||g" \
+ -e "s|@options@|env ELECTRON_OZONE_PLATFORM_HINT=auto|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
gendesk -q -f -n --pkgname="${_pkgname//./-}-bin" --categories="Development" --name="${pkgname%-bin}" --exec="${pkgname%-bin} %U"
asar e "${srcdir}/${_appname}-linux-"*/resources/app.asar "${srcdir}/app.asar.unpacked"