summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD90
-rw-r--r--fix.patch21
3 files changed, 93 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7e976b0fe58..e8b066b9eefc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,38 +1,45 @@
-# Generated by mksrcinfo v8
-# Wed Nov 8 22:12:03 UTC 2017
pkgbase = backintime
- pkgver = 1.1.24
- pkgrel = 1
+ pkgver = 1.4.3
+ pkgrel = 2
url = https://github.com/bit-team/backintime
arch = any
license = GPL
+ checkdepends = openssh
+ checkdepends = python-dbus
+ checkdepends = rsync
+ checkdepends = systemd
+ checkdepends = python-pyfakefs
+ checkdepends = oxygen-icons
+ checkdepends = python-pylint
makedepends = python
- source = backintime-1.1.24.tar.gz::https://github.com/bit-team/backintime/archive/v1.1.24.tar.gz
- sha256sums = 74f391217c3fc33cea75abbd758914a003c1ee3bf815f31a75e7dc4c7bf11960
+ source = backintime-1.4.3.tar.gz::https://github.com/bit-team/backintime/archive/refs/tags/v1.4.3.tar.gz
+ source = fix.patch
+ sha256sums = 89a1d9f1b766025d0219b7978e77ee91a5e25ef99ade164c1d8b5a9a3d273e65
+ sha256sums = 9c0eed1444db54891f4fad9397a892dce6c6962b2a8846b624778514f1769611
pkgname = backintime
- pkgdesc = Simple backup system inspired from the Flyback Project and TimeVault. QT4 GUI version.
- depends = backintime-cli=1.1.24
- depends = xorg-xdpyinfo
- depends = python-pyqt4
+ pkgdesc = Simple backup system inspired from the Flyback Project and TimeVault. Qt5 GUI version.
+ depends = backintime-cli=1.4.3
depends = libnotify
- depends = ttf-font
- depends = icu
depends = polkit
+ depends = python-dbus
+ depends = python-pyqt5
+ depends = xorg-xdpyinfo
optdepends = kompare: diff/patch frontend
optdepends = meld: diff/patch frontend
optdepends = python-keyring: store and access passwords safely
+ optdepends = qt5-translations: translate BIT dialogs into native language
pkgname = backintime-cli
pkgdesc = Simple backup system inspired from the Flyback Project and TimeVault. CLI version.
- depends = rsync
depends = cron
+ depends = fuse2
depends = openssh
- depends = python-keyring
depends = python-dbus
- depends = polkit
- optdepends = backintime: QT4 GUI version
+ depends = python-keyring
+ depends = rsync
+ depends = python-packaging
+ optdepends = backintime: Qt5 GUI version
optdepends = encfs: encrypted filesystem in user-space
optdepends = pm-utils: for laptops allows an option to not snapshot on battery
optdepends = sshfs: FUSE client based on the ssh file transfer protocol
-
diff --git a/PKGBUILD b/PKGBUILD
index d994fa553aae..67c8d91880ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,67 @@
-# Maintainer: graysky <graysky AT archlinux DOT us>
+# Maintainer: graysky <therealgraysky AT protonmail DOT com>
# Contributor: germar <germar DOT reitze AT gmail DOT com>
-pkgname=('backintime' 'backintime-cli')
+pkgname=(backintime backintime-cli)
_pkgname="backintime"
-pkgver=1.1.24
-pkgrel=1
-arch=('any')
+pkgver=1.4.3
+pkgrel=2
+arch=(any)
url="https://github.com/bit-team/backintime"
-license=('GPL')
-makedepends=('python')
-#source=("https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz")
-source=("$_pkgname-$pkgver.tar.gz::https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('74f391217c3fc33cea75abbd758914a003c1ee3bf815f31a75e7dc4c7bf11960')
+license=(GPL)
+makedepends=(python)
+checkdepends=(openssh python-dbus rsync systemd python-pyfakefs oxygen-icons python-pylint)
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/bit-team/$_pkgname/archive/refs/tags/v$pkgver.tar.gz"
+fix.patch)
+sha256sums=('89a1d9f1b766025d0219b7978e77ee91a5e25ef99ade164c1d8b5a9a3d273e65'
+ '9c0eed1444db54891f4fad9397a892dce6c6962b2a8846b624778514f1769611')
prepare() {
- cd "$_pkgname-$pkgver"
-
- # patches here
+ cd "$_pkgname-$pkgver"
+ patch -p1 -i ../fix.patch
}
build() {
- cd "$_pkgname-$pkgver/common"
- ./configure --python --no-fuse-group
- make
+ cd "$_pkgname-$pkgver/common"
+ ./configure --python --no-fuse-group
+ make
- cd "$srcdir/$_pkgname-$pkgver/qt4"
- ./configure --python
- make
+ cd "$srcdir/$_pkgname-$pkgver/qt"
+ ./configure --python
+ make
}
-test() {
- cd "$_pkgname-$pkgver/common"
- make test
+check() {
+ cd "$_pkgname-$pkgver/common"
+ make test
}
package_backintime-cli() {
- pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. CLI version."
- depends=('rsync' 'cron' 'openssh' 'python-keyring' 'python-dbus' 'polkit')
- optdepends=('backintime: QT4 GUI version'
- 'encfs: encrypted filesystem in user-space'
- 'pm-utils: for laptops allows an option to not snapshot on battery'
- 'sshfs: FUSE client based on the ssh file transfer protocol')
-
- cd "$_pkgname-$pkgver/common"
- make DESTDIR="$pkgdir" install
+ pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. CLI version."
+ depends=(cron fuse2 openssh python-dbus python-keyring rsync python-packaging)
+ optdepends=('backintime: Qt5 GUI version'
+ 'encfs: encrypted filesystem in user-space'
+ 'pm-utils: for laptops allows an option to not snapshot on battery'
+ 'sshfs: FUSE client based on the ssh file transfer protocol')
+
+ cd "$_pkgname-$pkgver/common"
+ make DESTDIR="$pkgdir" install
+ python -m compileall -d /usr "$pkgdir"/usr
+ python -O -m compileall -d /usr "$pkgdir"/usr
}
package_backintime() {
- pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. QT4 GUI version."
- depends=("backintime-cli=$pkgver" 'xorg-xdpyinfo' 'python-pyqt4' 'libnotify'
- 'ttf-font' 'icu' 'polkit')
-
- # note users can optionally install EITHER kompare OR meld but not both!
- optdepends=('kompare: diff/patch frontend'
- 'meld: diff/patch frontend'
- 'python-keyring: store and access passwords safely')
-
- cd "$_pkgname-$pkgver/qt4"
- make DESTDIR="$pkgdir" install
+ pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. Qt5 GUI version."
+ depends=("backintime-cli=$pkgver" libnotify polkit python-dbus python-pyqt5 xorg-xdpyinfo)
+ # note users can optionally install EITHER kompare OR meld but not both!
+ optdepends=('kompare: diff/patch frontend'
+ 'meld: diff/patch frontend'
+ 'python-keyring: store and access passwords safely'
+ 'qt5-translations: translate BIT dialogs into native language')
+
+ cd "$_pkgname-$pkgver/qt"
+ make DESTDIR="$pkgdir" install
+ python -m compileall -d /usr "$pkgdir"/usr
+ python -O -m compileall -d /usr "$pkgdir"/usr
}
+
+# vim:set ts=8 sts=2 sw=2 et:
diff --git a/fix.patch b/fix.patch
new file mode 100644
index 000000000000..e6b7fd430aac
--- /dev/null
+++ b/fix.patch
@@ -0,0 +1,21 @@
+From 3b6de69e076ebeed6421312575c06dc8f762a335 Mon Sep 17 00:00:00 2001
+From: aryoda <aryoda@users.noreply.github.com>
+Date: Fri, 2 Feb 2024 19:00:51 +0100
+Subject: [PATCH] Fix bug #1630: "make install" ignored $(DEST) in file
+ migration part
+
+PR #1633
+---
+diff --git a/qt/configure b/qt/configure
+index 0c4d3297..ac6cc873 100755
+--- a/qt/configure
++++ b/qt/configure
+@@ -149,7 +149,7 @@ printf "install:\n" >> ${MAKEFILE}
+
+ # Migration
+ printf "\t#clean-up installed old files that were renamed or moved in later BiT versions\n" >> ${MAKEFILE}
+-printf "\trm -f /etc/dbus-1/system.d/net.launchpad.backintime.serviceHelper.conf\n" >> ${MAKEFILE}
++printf "\trm -f \$(DEST)/etc/dbus-1/system.d/net.launchpad.backintime.serviceHelper.conf\n" >> ${MAKEFILE}
+ printf "\trm -f \$(DEST)/share/backintime/plugins/qt4plugin.py\n" >> ${MAKEFILE}
+ addNewline
+