summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD16
-rw-r--r--keyring1.1.12.patch24
-rw-r--r--pkexec1.1.12.patch33
4 files changed, 12 insertions, 77 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae0969330c53..ac5a7d370c5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,18 @@
# Generated by mksrcinfo v8
-# Fri Jun 24 06:24:57 UTC 2016
+# Mon Mar 6 21:56:19 UTC 2017
pkgbase = backintime
- pkgver = 1.1.12
- pkgrel = 4
+ pkgver = 1.1.14
+ pkgrel = 1
url = https://github.com/bit-team/backintime
arch = any
license = GPL
makedepends = python
- source = https://github.com/bit-team/backintime/archive/v1.1.12.tar.gz
- source = pkexec1.1.12.patch
- source = keyring1.1.12.patch
- sha256sums = 76036de6abdf5a2b2fbf66311c369dce7e3755fa778e5f01aa49bc2be68eb9f1
- sha256sums = b5be2317976db5d946047b5daa7ef75b029498225a9bb2763a18c93b07686e5e
- sha256sums = 9ae26aa553b7917771b97c3f0b16459ea0f79130a7505b09f1feba93d96c1025
+ source = https://github.com/bit-team/backintime/archive/v1.1.14.tar.gz
+ sha256sums = d97e1446434afc4694677fcb278fe84f9757f1ff62dcf71c5e9922ce0202f2b7
pkgname = backintime
pkgdesc = Simple backup system inspired from the Flyback Project and TimeVault. QT4 GUI version.
- depends = backintime-cli=1.1.12
+ depends = backintime-cli=1.1.14
depends = xorg-xdpyinfo
depends = python-pyqt4
depends = libnotify
diff --git a/PKGBUILD b/PKGBUILD
index 5a05f6ebc2da..892132d62f2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,19 @@
pkgname=('backintime' 'backintime-cli')
_pkgname="backintime"
-pkgver=1.1.12
-pkgrel=4
+pkgver=1.1.14
+pkgrel=1
arch=('any')
url="https://github.com/bit-team/backintime"
license=('GPL')
makedepends=('python')
-source=("https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz"
-'pkexec1.1.12.patch'
-'keyring1.1.12.patch')
-sha256sums=('76036de6abdf5a2b2fbf66311c369dce7e3755fa778e5f01aa49bc2be68eb9f1'
- 'b5be2317976db5d946047b5daa7ef75b029498225a9bb2763a18c93b07686e5e'
- '9ae26aa553b7917771b97c3f0b16459ea0f79130a7505b09f1feba93d96c1025')
+source=("https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('d97e1446434afc4694677fcb278fe84f9757f1ff62dcf71c5e9922ce0202f2b7')
prepare() {
cd "$_pkgname-$pkgver"
- patch -Np1 -i "$srcdir/keyring1.1.12.patch"
- patch -Np1 -i "$srcdir/pkexec1.1.12.patch"
+
+ # patches here
}
build() {
diff --git a/keyring1.1.12.patch b/keyring1.1.12.patch
deleted file mode 100644
index 4d4ce4581c7b..000000000000
--- a/keyring1.1.12.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/common/tools.py b/common/tools.py
-index e1da01b..c13fb06 100644
---- a/common/tools.py
-+++ b/common/tools.py
-@@ -597,6 +597,8 @@ def keyring_supported():
- except: pass
- try: backends.append(keyring.backends.kwallet.Keyring)
- except: pass
-+ try: backends.append(keyring.backends.kwallet.DBusKeyring)
-+ except: pass
- try: backends.append(keyring.backend.SecretServiceKeyring)
- except: pass
- try: backends.append(keyring.backend.GnomeKeyring)
-@@ -607,9 +609,9 @@ def keyring_supported():
- displayName = keyring.get_keyring().__module__
- except:
- displayName = str(keyring.get_keyring())
-- if backends:
-+ if backends and isinstance(keyring.get_keyring(), tuple(backends)):
- logger.debug("Found appropriate keyring '{}'".format(displayName))
-- return isinstance(keyring.get_keyring(), tuple(backends))
-+ return True
- logger.debug("No appropriate keyring found. '{}' can't be used with BackInTime".format(displayName))
- return False
diff --git a/pkexec1.1.12.patch b/pkexec1.1.12.patch
deleted file mode 100644
index db15bc037461..000000000000
--- a/pkexec1.1.12.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/qt4/backintime-qt4-root.desktop b/qt4/backintime-qt4-root.desktop
-index fef451b..61794c6 100644
---- a/qt4/backintime-qt4-root.desktop
-+++ b/qt4/backintime-qt4-root.desktop
-@@ -1,7 +1,7 @@
- [Desktop Entry]
- Name=Back In Time (root)
- GenericName=Backup
--Exec=pkexec backintime-qt4
-+Exec=/usr/bin/backintime-qt4_polkit %f
- Icon=document-save
- Terminal=false
- X-MultipleArgs=false
-diff --git a/qt4/backintime-qt4_polkit b/qt4/backintime-qt4_polkit
-new file mode 100644
-index 0000000..4a04190
---- /dev/null
-+++ b/qt4/backintime-qt4_polkit
-@@ -0,0 +1,2 @@
-+#!/bin/sh
-+pkexec --disable-internal-agent "/usr/bin/backintime-qt4" "$@"
-diff --git a/qt4/configure b/qt4/configure
-index 68803ca..a96e772 100755
---- a/qt4/configure
-+++ b/qt4/configure
-@@ -146,6 +146,7 @@ addNewline
- addComment "application"
- addInstallDir "/bin"
- addInstallFile "backintime-qt4" "/bin" "755"
-+addInstallFile "backintime-qt4_polkit" "/bin" "755"
- addNewline
-
- addComment "dbus service"