summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6024ea18511d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bake
+ pkgdesc = An easy to use build system. Designed to be make/autotools for the 21st century.
+ pkgver = 0.1.49
+ pkgrel = 1
+ url = https://launchpad.net/bake
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = itstool
+ makedepends = vala
+ source = https://launchpad.net/bake/0.1/0.1.49/+download/bake-0.1.49.tar.gz
+ md5sums = 20eda033c1482900da0cccfb90a77f6d
+
+pkgname = bake
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77c67f3cfa48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: spider-mario <spidermario@free.fr>
+# Contributor: Sergio Tortosa <sertorbe@gmail.com>
+pkgname=bake
+pkgver=0.1.49
+pkgrel=1
+pkgdesc="An easy to use build system. Designed to be make/autotools for the 21st century."
+arch=('i686' 'x86_64')
+url="https://launchpad.net/bake"
+license=("GPL3")
+makedepends=('itstool' 'vala')
+source=("https://launchpad.net/bake/0.1/${pkgver}/+download/bake-${pkgver}.tar.gz")
+md5sums=('20eda033c1482900da0cccfb90a77f6d')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+ ./bake-bootstrap --configure install-directory="$pkgdir/"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./bake-bootstrap install
+}