summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b240dec8fd66..5ea4c08b619c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = etcher
pkgdesc = Burn images to SD cards & USB drives, safe & easy
- pkgver = 1.3.1
- pkgrel = 3
+ pkgver = 1.4.3
+ pkgrel = 1
url = https://www.etcher.io/
arch = x86_64
license = apache
@@ -17,10 +17,11 @@ pkgbase = etcher
depends = alsa-lib
optdepends = libnotify: for notifications
optdepends = speech-dispatcher: for text-to-speech
- source = https://github.com/resin-io/etcher/archive/v1.3.1.tar.gz
+ options = !strip
+ source = https://github.com/resin-io/etcher/archive/v1.4.3.tar.gz
source = etcher-electron
source = etcher-electron.desktop
- sha256sums = a6d08e8e4cf37c233e47317967e29e637e3d1ed72861ae5b239828ffbf312921
+ sha256sums = 2c788bde217ce943fb783a8c3c437490da9aff28e673976c5468ae4365cee3ef
sha256sums = a64f79fe894c4828b515844703b1795448a4818a654f5d42d4f567f4d80998d1
sha256sums = 89291532fb6e6c5555b43d61c9ba3df103bca0eace040483884b86fd30dca3e4
diff --git a/PKGBUILD b/PKGBUILD
index 741aa9e1b762..750ad2b4003a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Andrew Stubbs <andrew.stubbs@gmail.com>
pkgname=etcher
-pkgver=1.3.1
-pkgrel=3
+pkgver=1.4.3
+pkgrel=1
pkgdesc='Burn images to SD cards & USB drives, safe & easy'
arch=(x86_64)
url='https://www.etcher.io/'
@@ -12,10 +12,11 @@ depends=(electron gtk2 libxtst libxss gconf nss alsa-lib)
makedepends=(npm python2 git)
optdepends=('libnotify: for notifications'
'speech-dispatcher: for text-to-speech')
+options=('!strip')
source=("https://github.com/resin-io/$pkgname/archive/v$pkgver.tar.gz"
'etcher-electron'
'etcher-electron.desktop')
-sha256sums=('a6d08e8e4cf37c233e47317967e29e637e3d1ed72861ae5b239828ffbf312921'
+sha256sums=('2c788bde217ce943fb783a8c3c437490da9aff28e673976c5468ae4365cee3ef'
'a64f79fe894c4828b515844703b1795448a4818a654f5d42d4f567f4d80998d1'
'89291532fb6e6c5555b43d61c9ba3df103bca0eace040483884b86fd30dca3e4')
@@ -32,8 +33,9 @@ build() {
-s linux \
-r x64 \
-t electron \
- -v "$(pacman -Q electron | sed 's/.\+ \(.\+\)-.\+/\1/')" \
- -p
+ -v "$(pacman -Q electron | sed 's/.\+ \(.\+\)-.\+/\1/')"
+ webpack
+ npm prune --production
}
package() {
@@ -43,10 +45,9 @@ package() {
install -d "$_appdir"
install package.json "$_appdir"
- cp -a lib "$_appdir"
- cp -a build "$_appdir"
- cp -a assets/icon.png "$_appdir"
- cp -a node_modules/ "$_appdir"
+ cp -a {lib,build,generated,node_modules} "$_appdir"
+ install -D assets/icon.png "$_appdir"/assets/icon.png
+ install -D lib/gui/app/index.html "$_appdir"/lib/gui/app/index.html
install -Dm755 "$srcdir"/etcher-electron "$pkgdir"/usr/bin/etcher-electron
install -Dm644 "$srcdir"/etcher-electron.desktop \