summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore3
-rw-r--r--Etcher.desktop6
-rw-r--r--PKGBUILD31
-rw-r--r--etcher6
-rw-r--r--etcher.pngbin0 -> 64773 bytes
6 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fdf2db22e318
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Mon Jun 6 14:27:07 UTC 2016
+pkgbase = etcher
+ pkgdesc = Burn images to SD cards & USB drives, safe & easy
+ pkgver = 1.0.0_beta.7
+ pkgrel = 1
+ url = http://www.etcher.io/
+ arch = i686
+ arch = x86_64
+ license = apache
+ noextract = Etcher-linux-x64.AppImage
+ options = !strip
+ source = etcher
+ source = Etcher.desktop
+ source = etcher.png
+ md5sums = b8ca5d4b0c8d8df96058da836704ba93
+ md5sums = 89f5cf77f164510b1f980820aaa4cf91
+ md5sums = 7bd70ef05c6293e36938240be2558091
+ source_i686 = https://resin-production-downloads.s3.amazonaws.com/etcher/1.0.0-beta.7/Etcher-linux-x86.AppImage
+ md5sums_i686 = 1118cf594b3eaee866ed246a8c0f38b5
+ source_x86_64 = https://resin-production-downloads.s3.amazonaws.com/etcher/1.0.0-beta.7/Etcher-linux-x64.AppImage
+ md5sums_x86_64 = 7f1da299a708d27d7f6b77cc1900ed6d
+
+pkgname = etcher
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b2535820e33b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/Etcher-*
+/src/
+/pkg/
diff --git a/Etcher.desktop b/Etcher.desktop
new file mode 100644
index 000000000000..2508b1d64568
--- /dev/null
+++ b/Etcher.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Name=Etcher
+Exec=/usr/bin/etcher
+Comment=Burn images to SD cards & USB drives, safe & easy
+Icon=/usr/share/etcher/etcher.png
+Type=Application
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61746bdd42fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Andrew Stubbs <andrew.stubbs@gmail.com>
+pkgname=etcher
+realver=1.0.0-beta.7
+pkgver=${realver//-/_}
+pkgrel=1
+pkgdesc="Burn images to SD cards & USB drives, safe & easy"
+arch=('i686' 'x86_64')
+url="http://www.etcher.io/"
+license=('apache')
+source=("etcher"
+ "Etcher.desktop"
+ "etcher.png")
+source_i686=("https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-linux-x86.AppImage")
+source_x86_64=("https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-linux-x64.AppImage")
+noextract=("Etcher-linux-x64.AppImage")
+options=("!strip")
+md5sums=('b8ca5d4b0c8d8df96058da836704ba93'
+ '89f5cf77f164510b1f980820aaa4cf91'
+ '7bd70ef05c6293e36938240be2558091')
+md5sums_i686=('1118cf594b3eaee866ed246a8c0f38b5')
+md5sums_x86_64=('7f1da299a708d27d7f6b77cc1900ed6d')
+
+package() {
+ local a=x86
+ [ "$pkgarch" == "x86_64" ] && a=x64
+
+ install -D "$srcdir/etcher" "$pkgdir/usr/bin/etcher"
+ install -D "$srcdir/Etcher-linux-$a.AppImage" "$pkgdir/usr/share/etcher/Etcher-linux-$a.AppImage"
+ install --mode=644 -D "$srcdir/etcher.png" "$pkgdir/usr/share/etcher/etcher.png"
+ install -D "$srcdir/Etcher.desktop" "$pkgdir/usr/share/applications/Etcher.desktop"
+}
diff --git a/etcher b/etcher
new file mode 100644
index 000000000000..433385ba2f0d
--- /dev/null
+++ b/etcher
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+DESKTOPINTEGRATION=no
+export DESKTOPINTEGRATION
+
+exec /usr/share/etcher/Etcher-linux-x64.AppImage
diff --git a/etcher.png b/etcher.png
new file mode 100644
index 000000000000..1bf5138c4e2d
--- /dev/null
+++ b/etcher.png
Binary files differ