summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3f0041820c0..4599b461d39c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Thu Aug 4 07:19:49 UTC 2016
pkgbase = bamtools
pkgdesc = C++ API & command-line toolkit for working with BAM data
- pkgver = 2.4.0
- pkgrel = 2
+ pkgver = 2.5.2
+ pkgrel = 1
url = https://github.com/pezmaster31/bamtools
arch = x86_64
arch = i686
@@ -11,10 +9,7 @@ pkgbase = bamtools
makedepends = cmake
depends = gcc-libs
depends = zlib
- source = bamtools-2.4.0.tar.gz::https://github.com/pezmaster31/bamtools/archive/v2.4.0.tar.gz
- source = lib-destination.patch::https://github.com/pezmaster31/bamtools/pull/82.patch
- md5sums = 6139d00c1b1fe88fe15d094d8a74d8b9
- md5sums = fb81680ab082f3214dfbd409505e7fc3
+ source = bamtools-2.5.2.tar.gz::https://github.com/pezmaster31/bamtools/archive/v2.5.2.tar.gz
+ sha256sums = 4d8b84bd07b673d0ed41031348f10ca98dd6fa6a4460f9b9668d6f1d4084dfc8
pkgname = bamtools
-
diff --git a/PKGBUILD b/PKGBUILD
index ae6fa677e152..74f9dbe031e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,20 @@
# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
pkgname=bamtools
-pkgver=2.4.0
-pkgrel=2
+pkgver=2.5.2
+pkgrel=1
pkgdesc="C++ API & command-line toolkit for working with BAM data"
arch=('x86_64' 'i686')
url="https://github.com/pezmaster31/bamtools"
license=('custom')
depends=('gcc-libs' 'zlib')
makedepends=('cmake')
-source=($pkgname-$pkgver.tar.gz::https://github.com/pezmaster31/bamtools/archive/v$pkgver.tar.gz
- lib-destination.patch::https://github.com/pezmaster31/bamtools/pull/82.patch)
-md5sums=('6139d00c1b1fe88fe15d094d8a74d8b9'
- 'fb81680ab082f3214dfbd409505e7fc3')
+source=($pkgname-$pkgver.tar.gz::https://github.com/pezmaster31/bamtools/archive/v$pkgver.tar.gz)
+sha256sums=('4d8b84bd07b673d0ed41031348f10ca98dd6fa6a4460f9b9668d6f1d4084dfc8')
prepare() {
cd $srcdir/$pkgname-$pkgver
- patch -Np1 -i $srcdir/lib-destination.patch
-
sed -e '/set( CMAKE_BUILD_TYPE Release )/a set( CMAKE_CXX_FLAGS_RELEASE "-std=c++98 ${CMAKE_CXX_FLAGS_RELEASE}" )' \
-i CMakeLists.txt