summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79d695e0c478
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bandwidth
+ pkgdesc = Benchmark memory and network bandwidth
+ pkgver = 1.1b
+ pkgrel = 1
+ url = http://home.comcast.net/~veritas/bandwidth.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = nasm
+ options = !makeflags
+ source = http://zsmith.co/archives/bandwidth-1.1b.tar.gz
+ md5sums = ae47329daea5c422f552e38b16856376
+
+pkgname = bandwidth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7d7ee7db8ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=bandwidth
+pkgver=1.1b
+pkgrel=1
+pkgdesc="Benchmark memory and network bandwidth"
+arch=('i686' 'x86_64')
+url="http://home.comcast.net/~veritas/bandwidth.html"
+license=('GPL')
+makedepends=('nasm')
+options=(!makeflags)
+source=(http://zsmith.co/archives/${pkgname}-${pkgver}.tar.gz)
+md5sums=('ae47329daea5c422f552e38b16856376')
+
+build() {
+ cd "${srcdir}"/${pkgname}-1.1
+ if [ "${CARCH}" = "x86_64" ]; then
+ make bandwidth64
+ else
+ make bandwidth32
+ fi
+}
+
+package() {
+ cd "${srcdir}"/${pkgname}-1.1
+ if [ "${CARCH}" = "x86_64" ]; then
+ install -Dm755 bandwidth64 "${pkgdir}"/usr/bin/bandwidth
+ else
+ install -Dm755 bandwidth32 "${pkgdir}"/usr/bin/bandwidth
+ fi
+}