summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
-rw-r--r--baresip-flags.patch45
3 files changed, 15 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52cf0692eca7..286dbfab9f73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = baresip
pkgdesc = portable and modular SIP User-Agent with audio and video support
- pkgver = 0.6.3
+ pkgver = 2.0.2
pkgrel = 1
- url = http://creytiv.com/baresip.html
+ url = https://github.com/baresip/baresip
arch = i686
arch = x86_64
arch = armv6h
@@ -27,6 +27,7 @@ pkgbase = baresip
makedepends = v4l-utils
depends = rem
depends = openssl
+ depends = re
optdepends = alsa-lib: (alsa module)
optdepends = cairo: (cairo, rst modules)
optdepends = ffmpeg: (avcodec, avformat, h265 modules)
@@ -45,10 +46,7 @@ pkgbase = baresip
optdepends = spandsp: (g722, g726,plc modules)
optdepends = speexdsp: (speex_aec, speex_pp modules)
optdepends = v4l-utils: (v4l2 module)
- source = http://creytiv.com/pub/baresip-0.6.3.tar.gz
- source = baresip-flags.patch
- sha256sums = c8005466b4947e28bc48ceb3d99608c782109970c2653b9d0eb0900d4695300c
- sha256sums = 55af521d77e105bb519f60464b2e50b83da15eb8549c18dabefa15215b22fa92
+ source = baresip-2.0.2.tar.gz::https://github.com/baresip/baresip/archive/v2.0.2.tar.gz
+ sha256sums = f1c48c336ca7300971619358f532367c7dabfc6e16b2b2bfc99646ed50271d93
pkgname = baresip
-
diff --git a/PKGBUILD b/PKGBUILD
index 3fcd9ef64d90..21de5f1daed9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
-# Maintainer: Andrew Sun <adsun701@gmail.com>
-# Contributor: Dmitrij D. Czarkoff <czarkoff@gmail.com>
+# Maintainer: Gustavo Heinz <gustavo at gsthnz dot com>
+# Contributor: Andrew Sun <adsun701 at gmail dot com>
+# Contributor: Dmitrij D. Czarkoff <czarkoff at gmail dot com>
pkgname=baresip
-pkgver=0.6.3
+pkgver=2.0.2
pkgrel=1
pkgdesc="portable and modular SIP User-Agent with audio and video support"
arch=('i686' 'x86_64' 'armv6h')
-url="http://creytiv.com/baresip.html"
+url="https://github.com/baresip/baresip"
license=('BSD')
depends=('rem'
- 'openssl')
+ 'openssl'
+ 're')
optdepends=('alsa-lib: (alsa module)'
'cairo: (cairo, rst modules)'
'ffmpeg: (avcodec, avformat, h265 modules)'
@@ -29,19 +31,12 @@ optdepends=('alsa-lib: (alsa module)'
'speexdsp: (speex_aec, speex_pp modules)'
'v4l-utils: (v4l2 module)')
makedepends=(${optdepends[@]/%:*/})
-source=("http://creytiv.com/pub/$pkgname-$pkgver.tar.gz"
- "baresip-flags.patch")
-sha256sums=('c8005466b4947e28bc48ceb3d99608c782109970c2653b9d0eb0900d4695300c'
- '55af521d77e105bb519f60464b2e50b83da15eb8549c18dabefa15215b22fa92')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i ${srcdir}/baresip-flags.patch
-}
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/baresip/baresip/archive/v${pkgver}.tar.gz")
+sha256sums=("f1c48c336ca7300971619358f532367c7dabfc6e16b2b2bfc99646ed50271d93")
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- make V=1 USE_GST= USE_GST_VIDEO= PREFIX="/usr"
+ make V=1 USE_GST= USE_GST_VIDEO= DESTDIR="/usr" PREFIX="/usr"
}
package() {
diff --git a/baresip-flags.patch b/baresip-flags.patch
deleted file mode 100644
index d19f5a0da970..000000000000
--- a/baresip-flags.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -Naur baresip-0.6.2.orig/Makefile baresip-0.6.2/Makefile
---- baresip-0.6.2.orig/Makefile 2019-05-06 19:50:16.033903247 -0400
-+++ baresip-0.6.2/Makefile 2019-05-06 19:51:38.941047245 -0400
-@@ -170,7 +170,7 @@
-
- $(SHARED): $(LIB_OBJS)
- @echo " LD $@"
-- $(HIDE)$(LD) $(LFLAGS) $(SH_LFLAGS) $^ -L$(LIBRE_SO) -lre $(LIBS) -o $@
-+ $(HIDE)$(LD) $(LDFLAGS) $(LFLAGS) $(SH_LFLAGS) $^ -L$(LIBRE_SO) -lre $(LIBS) -o $@
-
- $(STATICLIB): $(LIB_OBJS)
- @echo " AR $@"
-@@ -197,9 +197,9 @@
- $(BIN): $(APP_OBJS)
- @echo " LD $@"
- ifneq ($(GPROF),)
-- $(HIDE)$(LD) $(LFLAGS) $(APP_LFLAGS) $^ ../re/libre.a $(LIBS) -o $@
-+ $(HIDE)$(LD) $(LDFLAGS) $(LFLAGS) $(APP_LFLAGS) $^ ../re/libre.a $(LIBS) -o $@
- else
-- $(HIDE)$(LD) $(LFLAGS) $(APP_LFLAGS) $^ \
-+ $(HIDE)$(LD) $(LDFLAGS) $(LFLAGS) $(APP_LFLAGS) $^ \
- -L$(LIBRE_SO) -lre $(LIBS) -o $@
- endif
-
-@@ -210,7 +210,7 @@
-
- $(TEST_BIN): $(STATICLIB) $(TEST_OBJS)
- @echo " LD $@"
-- $(HIDE)$(CXX) $(LFLAGS) $(TEST_OBJS) \
-+ $(HIDE)$(CXX) $(LDFLAGS) $(LFLAGS) $(TEST_OBJS) \
- -L$(LIBRE_SO) -L. \
- -l$(PROJECT) -lre $(LIBS) $(TEST_LIBS) -o $@
-
-diff -Naur baresip-0.6.2.orig/mk/mod.mk baresip-0.6.2/mk/mod.mk
---- baresip-0.6.2.orig/mk/mod.mk 2019-05-06 19:50:16.037236599 -0400
-+++ baresip-0.6.2/mk/mod.mk 2019-05-06 20:04:34.508833761 -0400
-@@ -33,7 +33,7 @@
-
- $(MOD)$(MOD_SUFFIX): $($(MOD)_OBJS)
- @echo " LD [M] $@"
-- $(HIDE)$(LD) $(LFLAGS) $(SH_LFLAGS) $(MOD_LFLAGS) \
-+ $(HIDE)$(LD) $(LDFLAGS) $(LFLAGS) $(SH_LFLAGS) $(MOD_LFLAGS) \
- $($(basename $@)_OBJS) \
- $($(basename $@)_LFLAGS) -L$(LIBRE_SO) -lre -o $@
-